OpenSUSE Logs out when trying to run Virtualbox

Whenever I try to run anything in the virtual box manager (starting a vm, clicking on the settings tab etc.), my OpenSUSE host immediately logs out. I am using 12.3 on a 64 bit system. I am using Virtualbox 4.2.18, but I also had the issue with 4.2.16. My current VM is a 64bit windows 7 system.

If you are using the Nvidia proprietary driver, try re-installing it. This seems to have corrected the issue in some cases.

https://forums.opensuse.org/english/get-technical-help-here/applications/489724-virtualbox-4-2-16-terminates-kde-session.html

https://forums.opensuse.org/english/get-technical-help-here/virtualization/489598-linux-box-disconnect-when-clicking-settings-button-virtualbox-another-story.html

Do you have hardware virtualization support (AMD-V or Intel-VT) turned on in the BIOS if available?

I guess this could be a graphics driver problem as well. Which gfx card do you have and which driver are you using?
And please install “Mesa-demo-x” and post the output of:

glxinfo | grep render

Reinstalling the drivers fixed it, thanks!

On 10/14/2013 08:46 AM, 8ofspades wrote:
>
> Reinstalling the drivers fixed it, thanks!

When trying to troubleshoot this kind of problem, always remember that an X
crash lokks just like logging out.