openSUSE LiveUSB with unetbootin, again

Has anyone succeeded in creation of LiveUSB with unetbootin? I have tried several ways, and none works.

I have tried LiveCD images of 11.0, 11.1, Factory; FAT32 and ext3 filesystems; default initrd and the initrdud suggested on Spirit of Change. None works.

Meanwhile, installing from Fedora’s LiveCD image works from the first attempt.

If anyone has succeeded, could you please share the details:

Did you create the USB boot disk in opensuse? Which version of opensuse? 32 or 64 bit?

What LiveCD image did you use?

Did you replace the initrd?

Did you modify any other files?

What is the filesystem type of the USB disk’s partition?

There are several threads in this forum and in the web about LiveUSB for opensuse. I have tried many of the suggestions (besides the cpio one), but nothing helps.

However, the installation of the OS from USB, as described in the manual, works correctly.

What worked for me is to install 11.1 live image with unetbootin, then delete config.isoclient in the root of the installed system. Then, depending on whether you’ve used the GNOME or KDE image, rename config.gnome.isoclient or config.kde.isoclient to config.isoclient

Hope that helps.

[Also, if you’re really stuck, maybe try one of the respin / reloaded isos. I think some may be specifically designed for USB, and I know that the unofficial KDE 3.5 one works perfectly with unetbootin on USB. Well, for me at least… Good luck :)]

openSUSE 11.1 on LiveUSB is a story on its own. You may create one on your own (oemtype) using the kiwi build system. This one would be even persistent. It’s also possible to create such a LiveUSB for openSUSE 11.1 with SUSE Studio. The stock ISO isn’t deployable to LiveUSB without modifications on the initrd - as described by Vavai (you linked his blog).

As of openSUSE 11.2 the situation is to be changed. We now have two options for USB deployment on the table - hybrid iso (as of 11.2M4) and still oemtype. Both will be persistent but currently (as the time of writing) oemtype is broken in kiwi and hybrid iso comes with disabled write support. In the end you currently have the option to deploy the openSUSE 11.2M5 ISO directly to USB in a non-persistent way like that

# dd if=openSUSE-KDE4-LiveCD-Build0201-i686.iso of=/dev/"usbdrive" bs=4M

Be VERY CAREFUL with the selection of the “usbdrive” - this will erase ALL DATA on the target device.

I’ll post updates on this topic as available. Stay tuned!

PS: Factory (oemtype) images, which are (as I said) currently broken but persistent, are available at Index of /repositories/openSUSE:/Factory:/Live/images