OpenSuse-Linux 11.3: unable to install Ruby 1.9!

Hello dear community

i made very restrictive experiences with OpenSuse-Linux version 11.3.

I am not able to install Ruby 1.9. Everytime i want to do that i end up with Ruby 1.8.7

I need to test some ruby-scripts. Therefore i need Ruby with the following gems

mechanize
nokogiri
utf8_utils

Does anybody have some advices for me!? Does anybody run RUBY 1.9?

best regards
db1

BTW: Is it possible to run Ruby 1.9 and all with all that extensions on a USB-Stick!?
Well i want to try out this! If it is possible!?

dilbertone wrote:
> i made very restrictive experiences with OpenSuse-Linux version 11.3.
>
> I am not able to install Ruby 1.9. Everytime i want to do that i end up
> with Ruby 1.8.7

This may not be openSUSE but just you. Anyway it would help if you told
everyone how you tried to install that version and what failed.

Ruby 1.8.7 is packaged for openSUSE 11.3, same for the
devel:languages:ruby OBS project.

http://software.opensuse.org/search?q="ruby"&baseproject=openSUSE%3A11.3&lang=en

There is a 1.9.2 packages in a user’s home: project. I recommend that
you ask the maintainers of devel:languages:ruby to update the package or
you sumbit an updated package yourself.

> BTW: Is it possible to run Ruby 1.9 and all with all that extensions
> on a USB-Stick!?

See http://en.opensuse.org/SDB:Live_USB_stick

With kind regards,
Andreas Stieger