Opensuse leap EFI issue / dual boot


I have a Samsung New Series 9 (NP900X4D) Ultrabook since end of 2012 and I installed first opensuse 12.1, 12.3 and in the end 13.1 (each 64Bit) in parallel with Windows 7 Pro using grub. Now it seems that grub2-efi does not support my hardware anymore. See the details below.

Last weekend my opensuse 13.1 suddenly stopped booting.
I did not attempt to fix this but took this as a chance to finally install the new hardware I already bought a while before (500GB SSD + 16GB RAM).

So I first installed Windows 10 to give it a try. This was no issue at all - all was working well even without additional driver installs (surprise, never had this before!). But I’m not going to use this too much, my main OS since almost 15 years is Suse (first contact with Suse 5, seriously working with it since Suse 7.3 - but I always was just a user, not an expert).

Then I downloaded the opensuse 42.1 leap iso and put this on a USB key (using YUMI) to install. BIOS settings: UEFI + CSM, secure boot disabled.

During partitioning there was no mount point /boot/efi available in the drop-down list. I therefore added this manually for /dev/sda3.
Below the fdisk -l output, i edited the “Type” section with addition partition type and mount points (funnily, fstab is was recognizing the EXT4 partitions as “Microsoft basic data” - is this normal?). /dev/sda9 I added later after I read somewhere that I need a small efi-grub partition I never used on my previous installations. It’s a GPT partition table.

Device         Start       End   Sectors   Size Type
/dev/sda1         34    262177    262144   128M Microsoft reserved
/dev/sda2     264192   1163831    899640 439,3M Windows recovery environment (ntfs)
/dev/sda3    1185792   1390591    204800   100M EFI System /boot/efi
/dev/sda4    1390592 211105791 209715200   100G Windows 10 (ntfs)
/dev/sda5  211105792 244670463  33564672    16G swap
/dev/sda6  244670464 349526015 104855552    50G / (EXT4)
/dev/sda7  349526016 559239167 209713152   100G /home (EXT4)
/dev/sda8  559239168 976773119 417533952 199,1G /data (ntfs)
/dev/sda9    1165312   1185791     20480    10M BIOS boot (efi-grub)

After partition setup and software selection, I manually changed the Bootloader to “grub2-efi” but received the error message “unsupported combination of hardware platform x86 64 and bootloader grub2 efi”. This was a surprise. I did then change back to normal grub and the installation ran normally. I can boot opensuse now but only after inserting the USB key with the install media on it. There is no joint menu for Windows 10 and opensuse selection. That’s not what I want.

Since grub2-efi was working on my Laptop with several versions of opensuse without any issue before, do you have an idea what could have caused this incompatibility now? I assume that using a new SSD and new RAM should not have big influence on the UEFI BIOS (although 16GB is officially not supported by Samsung, but works).

Is there any way to get grub2-efi installed and configured to load the Windows bootloader or opensuse? Without reinstalling again (I did this already 4x during last weekend).
I always relied on the automated configuration of grub during install. I’m a complete newbie if that needs to be configured manually and would need some advises from experts.

Thanks a lot for your support!

with best regards

You need it only if using GPT with legacy BIOS. You booted installation media in legacy, non-EFI, mode, which the reason why it could not setup EFI bootloader for you and also why Windows is not offered (you cannot chainload EFI binary from legacy BIOS).

Is there any way to get grub2-efi installed and configured to load the Windows bootloader or opensuse? Without reinstalling again

Yes, but it depends on whether you can boot Linux (any live media actually) in EFI mode.

The use of YUMI is probably the main cause of your problems. It likely created a USB that did not support booting in UEFI mode.

Don’t need sda9 you share sda3 which should be FAT format and if you booted the installer in EFI mode should be set to mount as /boot/efi by default. Do not use any Linux boot helpers like YUMI just copy direct to the USB device (not to partition to the device) you can use dd or cp if doing it from Linux but Windows you need a pure copy program

Hi all,

Thanks for the replies. I did as advised and now grub2-efi was offered by the installation routine.
To me that’s a bit strange, because I used YUMI already for the installations before and EFI worked fine.

Anyway, now it works - thanks for your support

best regards