Opensuse Leap 42.2 start-up problem for user


I have problem with opensuse leap 42.2 start-up problem. I can log-in as a root but when i log-in as user, cannot happen anything. Just viewing log-in screen. than i press cancel button and as a root log-in it work.

I tried at this article but i cannot solve this.

Before happening this problem, installed these; anaconda3, jupyter, biopython, conda and last virtualanv and ipykernel.

Note: this computer is workstation and use many people.

Thanks in advance

As you already found out while creating this thread, taht you had to choose OTHER VERSION, because 42.2 is out of support. Now you can of course carry on using that system (without any security fixes provided of course) for a long time as long as you do not change much. But you installed several packages (from where?) and now you have a problem that most certain can not be solved by people here because they do not use 42.2 anymore and can not even try to install the same packages you installed to try and find out where things go wrong.

So, while it is still possible that someone here comes with a solution (some people know many things about the past), my advice would be to upgrade to 42.3 first (or wait for 15.0 that will be out in a week or so).

Actually i do not know source of these packages because i do not install them. I assumed he/she using conda and try to set up virtual machine or like that and establish network from the workstation to outside the campus(workstation location). Unfortunately, someone install those, and i must figure it out how system came to be. And i am not IT staff or something in addition there is not someone to solve this :(. I must. If any solution won’t be came out, i should upgrade. Thanks for advice.

In my opinion you should work out who is the system manager (the one who knows the root password) and thus responsible.

I think you are right, however there is no system manager. But I wish we had a system manager. That’s why I told you I had to figure it out. Maybe I could have explained wrong before. This computer is a in campus, but not participate any unit or system. Just a computer in a room which use for molecular modeling. And extra info: few people know root password including me. As far as i learned he/she who learn root password from these few people, want to study and install some packages, i do not know this problem reason is these packages. Maybe something else.

This sounds like a recipe for a disaster. Not an ideal way to manage such a system at all.

I know, but i have not authority that decide decision how to manage system. I am just a user who know solve simple problems and sometnig about OS but i am not manager. I warned many times but nobody listen me. In any cases i have to solve this :(. Anyway how solve this? are you think this upgrade solve?:

I know most people will try to be nice to each other (specially when they are one’s boss) and will try to help with problems. But I think they then may expect help from the other side also. That means in this case that you might try to help running/managing this system, but in return may ask that you are the only one to know the password (storing a copy of it in a sealed envelope in a save place for the case you run under a street car). Or you may ask a good amount of money for being the one that comes to the rescue when stupids ruined the system again.

I say this specially not for telling you the obvious, but e.g. one of the things I asked is where those packages where installed from. You did not answer that and I think I know why. Just because those who did it, did not tell you and, from the fact that they are just noobs knowing the root password, will not be able to tell you what they exactly did. And you not being able to tell us will make it rather difficult for us to help you. We are stuck on the same point as you: not enough information on what people did meddling on an outdated system.

I think, you are aware of my situation and you have summarized well. I have just learned who did. Unfortunately, who installed those have a computer engineering degree and when i asked questions and received vague answers. Anyway, i should not complain like that in this forum. I appreciated your answers and keep in my mind your advices and i am going to carry out.

The anaconda installer can add a line to ~/.bashrc that may break login for that user.
There already have been a couple of threads about this.

Open the file in a text editor (as root e.g. or login as the affected user in text mode or IceWM) and remove or comment out the line referring to anaconda and login should work again.
It should look similar to this:

export PATH=/home/xxx/anaconda3/bin/:$PATH

While i searched on saturday, i found the thread about you mentioned also i bookmarked :). However i tried and it did not work, after, i removed those package and unfortunately it did not work. Last, I looked snapshots and i found a snapshot which before those packages installation. rollbacked it and it worked. Now everything seems good.

Actually, First solution, i tried used snaphot and it solved problem but resolution was to bad, i assumed snaphots i tried before nvidia driver installation.

Thanks for all advices and solutions.