openSUSE Leap 42.2 - initial experiences

Following initial disappointment with Leap 42.1 (can we ditch the openSUSE name now?) but with its subsequent
improvements following updates, I was curious to see how much Leap 42.2 put my concerns to rest for three systems:

  1. Desktop - new install from DVD.
  2. Laptop - update from Leap 42.1.
  3. Workstation - new install from DVD.


HW: Intel Core i7-975 with AMD Radeon graphics card
OS: Quad-boot: Leap 42.1 (to replace), Win7, Linux Mint 17, Gentoo

I booted the installation DVD and was pleased to see it didn’t crash after the kernel loaded (the norm with previous
openSUSE DVDs on this machine). The installer ran fine, once you got past the crazy BTRFS subvolume suggestions -
honestly I think you need to be an `Expert Partitioner’ to propose such an arrangement rather than implementing a
simpler more traditional ext4/XFS GNU/Linux arrangement. Following installation, the system (sensibly) rebooted rather
kexec-loaded. In the run-up to Christmas I was slightly disappointed by the absence of the penguins at the bootloader
stage but it seems GRUB2 is far too sensible these days.

The KDE5 desktop loaded up without the pre-Leap Welcome screen. I have to say that Leap seems to be the only KDE5
GNU/Linux distribution that correctly handles USB devices. However, it wasn’t long before KWallet wanted to start
interfering with desktop experience but fortunately it could be tamed. After a `zypper up’ (which updated only a few
packages), and running my usual scripts for adding repos and packages (including the incredibly stupid >1600 texlive
packages), I rebooted. As expected, the machine rebooted to a terminal unable to start X because of issues with the
FGLRX driver.

Resigned to having to undertake inevitable fix at some future stage (i.e. installing FGLRX the hard way' or rather the only way that seems to work’), I just uninstalled FGLRX driver reverting to the open-source radeon driver, rebooted,
and successfully got back into X/KDE. It’s fine for now, except when I have to shutdown I have to manually power off the
machine after halting. Once again it seems that openSUSE/Leap seems to be only GNU/Linux distribution that is unable to
install FGLRX from the recommended repository correctly.

Apart from that, Leap 42.2 seemed to run very well. The unchanged default background is superb, the new Breeze theme is
tolerable this time, but the default Monospace font for consoles is just horrible. As I (with the rest of the
Python-programming world) am having to transition from Python 2 to 3, I needed to make changes to my installer scripts
to include python3 packages. Modern GNU/Linux distributions default to python3 from the python symlink and it would
probably be a good idea for a progressive distribution such as Leap to consider doing likewise. But this is just a minor


HW: Intel Core i7-975 with AMD Radeon graphics card
OS: Dual-boot: Leap 42.1 (to update), Win10

Historically, openSUSE has been very good when it comes to incremental updates and I was curious to see if this was the
same for Leap. It was. I couldn’t see two different (UEFI/non-UEFI) boot options from installer DVD (as was the case for
Leap 42.1) but I guessed perhaps it wasn’t critical for an update. The installer easily recognised the Leap 42.1
installation, updated the repositories and the update proceeded without a hitch.

My main issue here on a touchscreen-laptop is that KDE5 has not properly taken touchscreens seriously and the experience
feels positively antiquated compared to Windows 10. It’s nearly 2017. and here we still have a touchscreen-desktop that
can’t pinch to zoom or intelligently put up a useful touch keyboard. Apart from code refactoring what have the KDE guys
been up to for the last couple of years? If they continue to rest on their laurels, then they will rightly lose the

Having said all that, when I rebooted to Windows 10, Windows looked a little childish in comparison. But there was a
problem. Whatever I did in the UEFI menu, I couldn’t boot back into Leap. This wasn’t a problem before the update. Faced
with the inevitable `chroot to fix’, I thought it was a much more time-efficient option just to do a full reinstall
(which with scripts never takes me more than an hour). However I haven’t been brave enough to boot into Windows since,
but I’m not looking forward to occasion when I have to…


HW: Intel Xeon E5-2640-v3 with Nvidia Quadro card
OS: Triple-boot: openSUSE 13.2 (to replace), Win7, Gentoo

I maintain this workstation using a custom-compiled Gentoo meta-distribution for numeric analysis. Occasionally however
things go wrong and I need a backup go-to solution for emergencies. Following my experiences with Leap 42.1, I was not
willing to replace the well-behaved openSUSE 13.2 installation, but I was prepared to give Leap 42.2 a go.

Once again the UEFI BIOS could not distinguish a UEFI or non-UEFI version of the DVD bootloader (i.e. unlike for Leap
42.1), but it seemed to load a DVD version of GRUB (not ISOLINUX?). After selecting installation' the kernel loaded (completely I think) but then the system hard-crashed. Fortunately upon rebooting the DVD I could press e’ at the boot
menu to tweak the kernel call to include safe options (i.e. `ide=nodma apm=off vga=normal nosmp’) that allowed me to
boot the DVD and reach the installation program albeit with an extremely ugly resolution. Apart from the now-default
crazy BTRFS recommendations, everything proceeded very easily. For such installations, I really do like the way the
network configuration can be done before installation.

In contrast to the AMD FGLRX experience described above, the proprietary Nvidia driver installation went perfectly.
Otherwise the experience was very similar to the desktop experience described previously. The virtual consoles still
have an ugly low resolution (as does GRUB2) but that’s something I’m happy to sort out at a later stage. All packages
seem to run well, and I’m reassured and confident with this installation providing a reliable backup system for the


It’s a bit early to tell, but for me Leap 42.2 is a big leap from 42.1 in terms of reliability and stability. My
GNU/Linux uses might be limited' (i.e. programming and doing things mostly in consoles) and therefore I'm not likely to see the benefits from the many improvements to GUI-based applications. But what I can see is that the touchscreen-laptop experience of KDE5 remains poor and it is disappointing that the KDE team have languished on the matter. I'm aware that openSUSE is not KDE, but openSUSE has routinely set the benchmark for KDE GNU/Linux distributions with substantial collaboration between the two projects. I also believe that openSUSE has maintained its status as a distribution NOT
suitable for GNU/Linux beginners’. Until Leap does these three things, this will remain the case…

  1. Defaulting to fail-safe kernel settings for booting installation media.
  2. An installer option to default partitioning recommendations to `simple’ configurations rather than intimidating the
    user with obfuscated BTRFS subvolume arrangements.
  3. A YaST-based (or via KDE’s system-settings) GUI to navigate

… but I guess the harmonisation of Leap with SLED/SLES ends up with a highly reduced priority in trying to appeal to
GNU/Linux newcomers - which is fine. Beyond this however, I really do believe Leap 42.2 is by far the best and most
flexible binary GNU/Linux distribution. I think the team have done a wonderful job and should be warmly congratulated.
Well done!

You do realize the FGLRX (Go talk to AMD/ATI) driver is dead for the newer Xorg? Unless you have GCN cards (amdgpu/amdgpu-pro[proprietary driver] it’s radeon only…

No issues here with touchscreen on a DELL 5555 (but I use GNOME…) running the amdgpu driver.

If the system is set to boot in UEFI mode, the install medium will take care of it, however in some systems you may need to use the BIOS option to select the efi file. Once booted you can always confirm by running the efibootmgr command to confirm.

On 2016-12-19, malcolmlewis <> wrote:
> Hi
> You do realize the FGLRX (Go talk to AMD/ATI) driver is dead for the
> newer Xorg? Unless you have GCN cards (amdgpu/amdgpu-pro[proprietary
> driver] it’s radeon only…

No I didn’t; thanks for that. But that’s scandalous! No more purchase orders on AMD/ATi equipment again… ever!

I went with 42.1 from the start, in spite of some misgivings. I am now at 42.2.

My experience with 42.1 was already pretty good. The main problems were with Plasma 5, which wasn’t really ready for release (in my opinion). But it mostly worked out. Maybe I am not using the parts of KDE where the problems most show up.

The difference with 42.2, is that Plasma 5 is now in much better shape. It’s still not perfect, but working pretty well.

The general opensuse support has been excellent for both 42.1 and 42.2, and I take that to be due to basing on SLE.

I should add that I am not using “btrfs” (I chose “ext4”), and I do not have AMD graphics.