OpenSuse Leap 42.1 can't perform updates, although the computer is connected to internet

After restarting the newly upgraded system, I got an error message that online update can not be performed.

Download (curl) error for ‘’:

Error code: Connection failed

Error message: Failed to connect to port 80: Network is unreachable

But I am connected to the internet, I am sending this message from the same computer. I am also able to open the link I provided above.

I was able to start Yast the first time, but after closing it, when I tried launching it, it didn’t want to start anymore (no errors appeared). After restarting the computer, I am able to use again Yast. It seems to me a bit moody.

There is an xconsole with the following information (****, I lost the information: after selecting and pressing Ctrl C on the console, the messages disappeared and I don’t have anything left in clipboard…).
I will restart the computer, maybe I will be able to edit my post and add the message in here.

Question: if the network works, how can I convince the online update to use to the network?


I was able to copy the messages from xconsole. I had to remember not to use Ctrl C to copy. All I had to do was to select the text in xconsole, then come back here and press the middle button of the mouse…

Console log for 192-168-1-106
2015-11-07T16:06:20.408048+11:00 linux-3x5u kernel:     0.000000] ACPI: RSDP 0x00000000000FEB00 000024 (v02 DELL  )
2015-11-07T16:06:20.408055+11:00 linux-3x5u kernel:     0.000000] ACPI: XSDT 0x00000000000FD257 00005C (v01 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408057+11:00 linux-3x5u kernel:     0.000000] ACPI: FACP 0x00000000000FD34F 0000F4 (v03 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408060+11:00 linux-3x5u kernel:     0.000000] ACPI: DSDT 0x00000000FFFD4952 003DA4 (v01 DELL   dt_ex    00001000 INTL 20050309)
2015-11-07T16:06:20.408062+11:00 linux-3x5u kernel:     0.000000] ACPI: FACS 0x00000000DFE86C00 000040
2015-11-07T16:06:20.408064+11:00 linux-3x5u kernel:     0.000000] ACPI: FACS 0x00000000DFE86C00 000040
2015-11-07T16:06:20.408066+11:00 linux-3x5u kernel:     0.000000] ACPI: SSDT 0x00000000FFFD8815 0000AA (v01 DELL   st_ex    00001000 INTL 20050309)
2015-11-07T16:06:20.408068+11:00 linux-3x5u kernel:     0.000000] ACPI: APIC 0x00000000000FD443 000072 (v01 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408075+11:00 linux-3x5u kernel:     0.000000] ACPI: BOOT 0x00000000000FD4B5 000028 (v01 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408077+11:00 linux-3x5u kernel:     0.000000] ACPI: ASF! 0x00000000000FD4DD 000067 (v16 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408079+11:00 linux-3x5u kernel:     0.000000] ACPI: MCFG 0x00000000000FD544 00003E (v01 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408082+11:00 linux-3x5u kernel:     0.000000] ACPI: HPET 0x00000000000FD582 000038 (v01 DELL   GX620    00000007 ASL  00000061)
2015-11-07T16:06:20.408393+11:00 linux-3x5u kernel:     0.050504] ACPI: All ACPI Tables successfully acquired
2015-11-07T16:06:20.408560+11:00 linux-3x5u kernel:     0.193885] ACPI Exception: AE_NOT_FOUND, While evaluating Sleep State \_S2_] (20150410/hwxface-580)
2015-11-07T16:06:20.409056+11:00 linux-3x5u kernel:     0.324170] ACPI: Enabled 1 GPEs in block 00 to 1F
2015-11-07T16:06:20.409083+11:00 linux-3x5u kernel:     0.325760] Expanded resource reserved due to conflict with PCI Bus 0000:00
2015-11-07T16:06:20.409641+11:00 linux-3x5u kernel:     0.389678] pci 0000:00:1f.0: BAR 13: [io  size 0x0080] has bogus alignment
2015-11-07T16:06:20.411042+11:00 linux-3x5u kernel:    13.775662] intel_rng: Firmware space is locked read-only. If you can't or
2015-11-07T16:06:20.411050+11:00 linux-3x5u kernel:    13.775662] intel_rng: don't want to disable this in firmware setup, and if
2015-11-07T16:06:20.411053+11:00 linux-3x5u kernel:    13.775662] intel_rng: you are certain that your system has a functional
2015-11-07T16:06:20.411055+11:00 linux-3x5u kernel:    13.775662] intel_rng: RNG, try using the 'no_fwh_detect' option.
2015-11-07T16:06:20.411057+11:00 linux-3x5u kernel:    13.813395] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x000000000000082A-0x000000000000082A (\GIC3) (20150410/utaddress-254)
2015-11-07T16:06:20.411060+11:00 linux-3x5u kernel:    13.813410] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x000000000000082B-0x000000000000082B (\GIC2) (20150410/utaddress-254)
2015-11-07T16:06:20.411062+11:00 linux-3x5u kernel:    13.813417] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x0000000000000828-0x000000000000082D (\GLBC) (20150410/utaddress-254)
2015-11-07T16:06:20.411071+11:00 linux-3x5u kernel:    13.813424] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x000000000000082A-0x000000000000082A (\SACT) (20150410/utaddress-254)
2015-11-07T16:06:20.411074+11:00 linux-3x5u kernel:    13.813431] ACPI Warning: SystemIO range 0x0000000000000828-0x000000000000082F conflicts with OpRegion 0x0000000000000828-0x0000000000000828 (\SSTS) (20150410/utaddress-254)
2015-11-07T16:06:20.411079+11:00 linux-3x5u kernel:    13.813443] ACPI Warning: SystemIO range 0x00000000000008B0-0x00000000000008BF conflicts with OpRegion 0x00000000000008B8-0x00000000000008B8 (\GHI0) (20150410/utaddress-254)
2015-11-07T16:06:20.411084+11:00 linux-3x5u kernel:    13.813452] ACPI Warning: SystemIO range 0x0000000000000880-0x00000000000008AF conflicts with OpRegion 0x000000000000088E-0x000000000000088E (\GIC1) (20150410/utaddress-254)
2015-11-07T16:06:20.411096+11:00 linux-3x5u kernel:    13.813465] lpc_ich: Resource conflict(s) found affecting gpio_ich
Console log for 192-168-1-106
2015-11-07T16:06:57.971841+11:00 192-168-1-106 kernel:    57.333853] show_signal_msg: 99 callbacks suppressed


Check the actual url of the repos via;

zypper lr -d

It can also be that the mirror your using is not populated…

Click on this link;

Find a mirror close in the list and add this as a new one and disable the old one. Use YaST software repositories or zypper from the command line.

Hi Malcolm,

I just fixed it. I edited the network interface and I added the IP address for the gateway (previously I selected DHCP and I thought it takes care of the gateway as well? It is strange that the browser was working and Online Update not). I also removed the IP6. Probably that has nothing to do with it


I’ve just completed a clean install of OpenSuse Leap42.1. After installation, the network still didn’t work (using a NetXtreme BCM5751 Gigabit Ethernet PCI Express network card). Both Firefox and Online Update could not connect. I set the gateway (I left the IP4 and IP6) and I still could not connect. Then I only left IP4 and I was able to PING a website. Mozilla Firefox still didn’t work. After I restarted the computer, Firefox started working. Online Update still reporting errors. I can open the location in the browser and I can see the files in there.
To me it looks like there is a need for some improvements in this version of OpenSuse Leap42.1. In the past I installed a few other versions on this computer and I don’t think they had problems with the network. I wonder if it is a leap in the right direction? :slight_smile:


So, since I installed a clean version of OpenSuse Leap 42.1, the system was unable to connect to perform online updates. However, the “Software updates” status informs me that my system is up to date, with the last check performed a few minutes ago. This looks like a bug to me. Just because the system attempted to perform the online updates (and failed), it does not mean that the system is up to date…

I think I figured it out. I had to untick the option “Enable IPv6” under Global Options of the network settings. Now I got into other problem. There is a green shield called “Software updates - Plasma” and it’s been running for about five minutes and nothing happens.
If I start Yast->Online Updates, it informs me that “PackageKit” is blocking software management and it offers to kindly ask PackageKit to quit. But PackageKit is a stubborn son of a bit… and it doesn’t respond. Also, it doesn’t want to quit :slight_smile: There is no abort button for this software. And Ctrl + Shift + Escape does nothing in Linux… Probably it’s time for another computer restart. At least, I’m having fun…


After restarting the computer, the Windows Updates from the tray was able to identify what updates are required and it downloaded and installed them all. This means this software does what it’s supposed to do, but just in ideal conditions. If there is no network available, it will try forever to download. Even if the network gets working in the meantime, if it had no network when it started checking for updates, it won’t do anything. It also does not listen when other software ask it to quit - obviously there could be some improvements done here. At least have an abort button to stop checking for updates. Maybe abort after one minute of failure to get any updates. Allow another software to stop it, if the user decides so.