OpenSuse Leap 42.1 and no sound out of the speakers

I installed OpenSuse Leap 42.1 on a pretty old laptop, HP 6530b. The sound works but only from headphones. The speakers are silent.

I did some research and it’s apparently a pretty common issue. However, the old solutions don’t work anymore on OpenSuse Leap 42.1.

The recommended solution is to put either

 options snd-hda-intel model=laptop


 options snd-hda-intel model=mobile

to the end of the /etc/modprobe.d/sound file. The file doesn’t exist anymore, there is 50-sound.conf instead but I suppose it works the same way. Unfortunately, putting either of those lines there won’t make the sound work.

Any ideas?

Here is some info about the card:

linux-gmj3:/proc/asound # cat cards 
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0x98900000 irq 31
linux-gmj3:/proc/asound # head -n 1 card0/codec#0
Codec: Analog Devices AD1984A
linux-gmj3:/proc/asound # head -n 1 card0/codec#1
Codec: LSI ID 1040
linux-gmj3:/proc/asound # 

Hi, my test box apparently has a similar sound card. It works OK in general, but occasionally it wakes up in the “Headphone only” mode, maybe when it was shutdown with a headphone inserted.
When that happens, choosing “Internal Speakers” as the “Device for sound output” in the desktop settings “Sound” applet in Gnome restores sound to the speakers. Hope it works the same in KDE.
A “stronger” alternative might be to install pavucontrol, or check alsamixer in case the speakers have been accidentally muted (by Windows?).
I never had to tweak snd-hda-intel on that machine…

I’m not sure if this is the same problem. First of all, I’m using XFCE, therefore no pulse and no fancy UI configurators, just plain old Alsa mixer plus corresponding frontends. I checked the volume levels and everything seemed alright. I don’t know how to “select the device for sound input” using plain Alsa.

Yes I have the same problem with Xfce , haven’t figured out a solution yet except…using another Desktop Environment (sound works fine in gnome and kde). Maybe you could use lxde? See if the problem is present there too.

It sounds a bit ridiculous that the desktop environment would affect something like this. As both KDE and Gnome are using pulse, do you think that switching to pulse in XFCE (if possible) could solve the problem?

I tried to switch to Pulse (you can do that in Yast) but it didn’t help. To be honest, with Pulse the sound stopped working completely, I couldn’t hear anything even when using headphones. But what was interesting was that when I run pavucontrol, I could see that some sound is being played (you can see there the bar moving as something is played). But nothing was coming out.

Two interesting observations:

  1. The “speakers” were marked as not available in pavucontrol.
  2. The volume control in Yast that was controlling the volume of the headphones was actually labeled “speakers”.

In my opinion, my problem is really more “low level”. The alsa driver does not seem to be configured properly. As mentioned in the initial post, I tried the tricks that I found in those 5-6 year old posts but it didn’t help in modern OpenSuse. I’d still appreciate any tips.

I have used all DEs of openSUSE Leap DVD and only in Xfce I didn’t have sound. I don’t remember about lxde but I’m pretty confident it worked there. In my opinion DE’s play an important role in how your system responds. For example KDE takes a lot more to reboot than gnome. (a bit irrelevant but you get the idea)
But I would like to learn how to fix the issue too, I wish I could help you more :shame:

Please check if anything here or inthis thread is of any help.
Also found the suggestion to add your user to the “audio” group; it should do no harm anyway.

An interesting quote from this page, hoping that it might be relevant to Leap 42.1 XFCE as well

One personal quibble I have is that Tumbleweed Xfce does not install PulseAudio support by default and ALSA just does not work well on it’s own with my onboard sound solutions.

Luckily this is easily remedied; First I installed the alsa-plugins-pulse, pavucontrol and xfce4-panel-plugin-pulseaudio packages, along with their dependencies, in order to pull in PulseAudio. Once that is done you can open YaST’s /Hardware/Sound module and use the “Other” button on bottom right to select “Pulse Audio Configuration” and then select “Enable Pulse Audio Support”. At this point remove the existing Audio Mixer applet from the panel and add the “Pulseaudio Plugin” via the panel’s “Add/Remove” functionality, then reboot the system.

Afterward, sound under PulseAudio will likely “just work”, but if necessary you can use PulseAudio Volume Control to disable unused audio devices like HDMI if they are not being used, so that the correct device becomes default.

Thank you guys for your tips. Unfortunately, still no luck. I tried couple of things mentioned in those threads and I also tried to completely switch to pulse. With pulse, I get no sound at all. I can actually hear some noise in the headphones when I change the output device (from headphones to speakers and back) or change the volume, and I can also see in the pavucontrol that something is playing, but I can’t hear the actual sound. With the with default settings (just pure alsa), I get at least the sound in headphones.

The thing is that the laptop is going to be used as a desktop machine, ie it’s not going to move very much. So I’ll just connect a couple of external speakers to it and that will solve the problem :slight_smile:

Did that solved the problem?


I’m having a similar problem here (using 42.2). I do get sound from the speakers after reboot, but only for about 30 seconds. After that, I only get sound from the headphones.

About my sound card:

nico@noel:/proc/asound> cat cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xc0600000 irq 27

All sound controls both from alsamixer and pavucontrol seem correct. I tried adding the lines mentioned to /etc/modprobe.d/50-sound.conf, but that did not solve the problem.

Any new ideas?


Hi nicovai. Please start your own thread with descriptive title to catch the attention of those who can help. Take the time to read the troubleshooting guide as well

In particular, running the (diagnostic script supplied as part of alsa) may yield important information that you can share in your thread.

I’ll do that, thanks!