opensuse Leap 15 KDE sometimes stuck on boot

Hi,
My setting of opensuse 15 is to boot automatically in KDE mode (plasma 5). I noticed that the screen freezes (sometimes) during the usage of opensuse 15 in KDE mode. Furthermore, during the boot time, sometimes, the boot sequence seems to get stuck on KDE splash screen logo the black one (after gnome leap logo the green one). I can move the mouse icon on that screen, therefore the screen is not frozen, but the boot seems to be stuck. I am switching back to boot in gnome mode to find out if I am getting the same symptoms. Any suggestions?

I see you have no answers until now. That maybe for several reasons.

You should see the difference between boot and login. A system does not boot into eKDE and/or Gnome, it just boots. After this there may come a user that logs in. You may have made that login automaticaly for a certain user, but it is still a log in. That user then may use KDE. So I guess your problem is with a user that logs in into KDE.

This means that you could do some further testing by loging out after a succesfull log in and then try a login again. Does it stuck then? At random or not? You may also want to switch off the automatic log in to have a more clear view of what happens when (on boot or on log in).

Because you reposrt screen locks, it may be of interest what graphics card you have and which deiver you use for it.

All this to give potential helpers more information.

@hcvv,
I switched back from gnome to KDE and disabled the automatic login. Therefore it is manual now. I will have to run openSUSE leap 15 like this for at least five days to determine if that makes a difference as you suggested.
Regarding graphics, I used lshw -c video command to get the following output:

  description: VGA compatible controller
       product: 82Q963/Q965 Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:f0400000-f04fffff memory:e0000000-efffffff ioport:1200(size=8) memory:c0000-dffff

It is build in graphics card. I do not know how to determine what driver I am using for this.

:slight_smile:
That should not be an issue. Create a new user, login as that user and see if that new user experiences the same issues.
Did you add any repos?

zypper lr -d
$ grep RETT /etc/os-release
PRETTY_NAME="openSUSE Leap 15.0"
$ sudo zypper in inxi
...
(1/1) Installing: inxi-2.3.40-lp150.1.3.noarch .............................................[done]
$ inxi -Gxx
Graphics:  Card: Intel 82Q963/Q965 Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:2992
           Display Server: X.Org 1.19.6 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.97hz
           OpenGL: renderer: Mesa DRI Intel 965Q version: 2.1 Mesa 18.0.2 Direct Render: Yes
$

If you find yours reports “drivers: intel” rather than modesetting, you can try modesetting by removing the package xf86-video-intel with zypper or yast and restarting X. If it reports neither, but instead fbdev or vesa, then you may need to remove nomodeset from your grub stanza(s).

new observation:

  1. In KDE mode, while browsing using Firefox, the screen froze again but mouse icon was active.
  2. This is new and possible a bug. I used yast, user security option, to disable the automatic login. Later I used to terminal command and mentioned before to switch from KDE to GNOME. Terminal command shows that changes are made but after turning off and on, the effect is not there. I am still at login screen, and it is still set to plasma.

I decided to go back to GNOME to operate PC in GNOME mode to see if I have login stuck and desktop freeze effect as well. I will keep testing in that mode for five days. Through that time I will make no attempt to troubleshoot KDE. I will keep you posted.

Note: my Graphics driver is Intel.

xorg/driver/xf86-video-intel - Intel video driver (mirrored from https://gitlab.freedesktop.org/xorg/driver/xf86-video-intel) shows the last official release of the intel driver was 4 years ago. It may be worth trying the modesetting alternative if you seem to have video-related issues. Modesetting is the only driver I use for Intel gfx devices it supports.

@mcmazda, how do you setup modesetting alternatives driver?

As directed in #5 is one way.

After 5 days of using opensuse leap 15 in gnome mode, I had no issues. Except that file manager had background black shaded and dark letter which makes files reading impossible. I have no way of changing that. But I had no login stuck in automatic mode, and no desktop screen freezing (except mouse icon). Therefore I conclude that issues are related to KDE mode setting. For login stuck issue, the solution seems to be by login manually. For desktop screen freezing, the driver should not be the issue because I believe that gnome and kde modes use the same graphics card driver. Therefore, there must be some thing else causing it.

Something happened in Gnome mode. When I decided to logout to go to login screen to switch to KDE mode, the login screen has changed. To get the list of desktop list I use gear icon on the left side of login button. In the gear button menu there is no longer KDE option. It is gone. Instead I have:
GNome
Gnome on Xorg
IceWM session
IceWm session
TWM

The plasma option that will take me to KDE desktop session is gone. Have I done something to it unwittingly or the system updated atomatically by erasing the plasma option? Does that mean that KDE option is removed for good?

this is bad. I run gnome mode opensuse and for some reason the desktop froze (except for mouse icon). At that time I was running firefox and switching the keyboard language… After waiting I rebooted using the power switch. When I got back (standard boot and advanced option boot) the desktop screen is still frozen (except for mouse icon). OpenSUSE is rendered completely useless. I cannot run in GNOME mode too. I rebooted 3 times and still the same situation. HOW DO I FIX THIS?! Please help.