opensuse leap 15 install flashing login text

Upgrade from leap 43 to leap 15
Now I cannot login anymore no gui and flashing login text.
How to solve this , Ctrl+F1 or Ctrl+ F2 to stop and get in text mode does not work.
Need to start Yast in text mode because I think nvidia needs reinstalled.


Hit ‘e’ on the boot menu. Scroll down to find the line that begins “linux” (or maybe “linuxefi”)
Append " 3" to the end of that line. Continue booting. That should take you to text mode.

Can t find Command 3
Not working

I’m not sure what you got wrong, because I wasn’t there to watch.

The ‘3’ isn’t a command. It is a kernel option appended to the end of the line that loads the kernel. So it should not give that error if you did it correctly.

As far as I know, you could even put a nonsense word there, and the kernel would just ignore it, but show it in the boot command line in case other commands are looking for it.

In this case it should indicate to boot to level 3, which is a command line boot instead of a graphic interface boot.

Just placed a 3 at the end of the line 1 which starts with linux. Not working no text mode the command login keeps flashing. Never seen this before. Gpu is nvidia geforce 1050t

… just to be sure: You went to the line that starts with linux, then hit the End key to get to the end of the line? It wraps, so it is necessary to hit the End key. You also need to add a space before the 3.

Yes I did that.
I now only get a black screen with a flashing monitor light . Nothing works. Only ctrl alt del to restart. Upgrading is again not a good idea when using opensuse. Think I have to do a new install unfortunately.

Try Alt-F1 or Ctrl-Alt-F1.

Alt-F1 or Ctrl-Alt-F1 did nothing.
Switched to onborad AGO rebooted and I am now in Yast text mode trying to solve the problem.

Need the zypper add nvidia repositorie link for opensuse leap 15 . Anyone.
Hopefully in the future nvidia will be included when upgrading the OS.


zypper ar -f -n nvidia nvidia

Thanks already solved the problem renamed etc/X11/org.conf mv xorg.conf xorg.old
The I could login eith a GUI started yast ans added repositorie community nvidia.
Back to software management view repositorie select nvidia and choose G04 driver installed and reboot. All works fine now.

After renaming mv xorg.conf xorg.old I could login in GUI. Added repositorie communitie nvidia . Software management installed nvidia G04 drivers reboot. All works fine now. Thanks for the zypper nvidia link command.

And again upgrade with yas tf packages cannot login anymore flashing screen text screen login E add search linux added 3 F10 did not work also Alt F1 or Ctrl F1 did not work. Frustrating Leap 15 why no save gui mode ? That was possible with suse 8.

8 was a very long time ago LOL and it was Suse then not openSUSE

openSUSE is open source only has NO proprietary drivers/programs, Note the name

did you put a space in front of the 3 to indicate a new parameter??? Appending it to an existing one will not do a nothing to help

ctrl-alt-F1 is the key not ctrl-Fi and alt-F1. But that may not work unless certain things are right.

What do you mean by “save gui mode” and Which GUI??? I assume you want to save the state of the GUI so your current programs are open when you reboot? Still can be done it is not default however and does depends on the GUI being used.

I meant safe mode and wrote Suse.
Anyhow problem solved got logged in then renamed xorg.conf to xorg.old