Opensuse Leap 15.4 Wayland Session Login Loop

Hello friends

I quite like OpenSuse, it’s quite nice that it doesn’t cause viruses except for minor problems. But I have a problem, I think something went wrong after I disable KDE Wallet in the settings because it keeps popping up. Or, more likely, it happened when I connected it to the home path via YAST partitioning to automatically mount the partition with Windows 10 installed.

The problem appeared when the laptop restarted and was basically a login loop. Every login attempt seemed to be successful, but it would eventually redirect me back to the login screen. Fortunately, I was able to overcome the problem for X11 session and with snapshot rollback I can now log in without any problem. However, I still have a login loop for Wayland.

inxi -F

System:    Host: nitro5 Kernel: 5.14.21-150400.24.63-default x86_64 bits: 64 Desktop: KDE Plasma 5.24.4
           Distro: openSUSE Leap 15.4
Machine:   Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04 serial: <superuser required>
           Mobo: RO model: Stonic_RNS v: V1.04 serial: <superuser required> UEFI: Insyde v: 1.04 date: 02/04/2021
Battery:   ID-1: BAT1 charge: 47.1 Wh (89.4%) condition: 52.7/58.8 Wh (89.8%)
CPU:       Info: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP cache: L2: 4 MiB
           Speed: 1644 MHz min/max: 1400/2900 MHz Core speeds (MHz): 1: 1644 2: 1396 3: 1397 4: 1397 5: 1396 6: 1396 7: 1397
           8: 1443 9: 1395 10: 1455 11: 1397 12: 1397 13: 1397 14: 1592 15: 1397 16: 1397
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] driver: nouveau v: kernel
           Device-2: Advanced Micro Devices [AMD/ATI] Renoir driver: amdgpu v: kernel
           Device-3: Quanta HD User Facing type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.3 driver: loaded: amdgpu,ati,modesetting,nouveau unloaded: fbdev,vesa
           resolution: 1920x1080~144Hz
           OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.14.21-150400.24.63-default LLVM 11.0.1) v: 4.6 Mesa 21.2.4
Audio:     Device-1: NVIDIA driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
           Device-3: Advanced Micro Devices [AMD] Family 17h/19h HD Audio driver: snd_hda_intel
           Sound Server-1: ALSA v: k5.14.21-150400.24.63-default running: yes
           Sound Server-2: PulseAudio v: 15.0 running: yes
           Sound Server-3: PipeWire v: 0.3.49 running: yes
Network:   Device-1: Realtek driver: r8169
           IF: eth0 state: down mac: 08:97:98:b9:d9:c6
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
           IF: wlan0 state: up mac: e0:d4:e8:99:0b:60
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb
           Report: bt-adapter ID: hci0 rfk-id: 4 state: down bt-service: enabled,running rfk-block: hardware: no software: yes
           address: E0:D4:E8:99:0B:64

How to repair it?


Hello, welcome to the openSUSE (yes, it is written this way) forum.

Sorry, but I do not quite understand this. KWallet is a feature of the desktop and thus works at the users level if a user is logged in.

Mounting file systems at boot is something done on the system level and way before a user is logged in and thus long before KWallet may be activated (or not).

Also I do not quite understand what you mean with “connected to the home path”.

It is always better to not only tell some story, but to show the system evidences that prove your story. Thus in the case you want to tell us something about a file system to be mounted at boot, please show:

cat /etc/fstab

to allow all of us to see what you mean.

cat /etc/fstab

UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /                      btrfs defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120                       0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /var                   btrfs subvol=/@/var,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120         0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /usr/local             btrfs subvol=/@/usr/local,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120   0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /tmp                   btrfs subvol=/@/tmp,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120         0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /srv                   btrfs subvol=/@/srv,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120         0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /root                  btrfs subvol=/@/root,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120        0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /opt                   btrfs subvol=/@/opt,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120         0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /home                  btrfs subvol=/@/home,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120        0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /boot/grub2/x86_64-efi btrfs subvol=/@/boot/grub2/x86_64-efi    0 0
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /boot/grub2/i386-pc    btrfs subvol=/@/boot/grub2/i386-pc       0 0
UUID=766D-CFA8                             /boot/efi              vfat  utf8                                0 2
UUID=eeffc873-1c1f-47a4-a8a6-b83511ba1a8e  /.snapshots            btrfs subvol=/@/.snapshots,defaults,noatime,compress=zstd:3,space_cache,autodefrag,discard=async,commit=120  0 0
UUID=7de41d51-ce8d-4d35-9dbe-8701fc83a7a3  swap                   swap  defaults                          0 0

When I login, at startup KDE was asking me Windows’ partition password to be mounted. Then I investigated on this and applied some advices. Like below;

Then something went wrong and I undo changes so my fstab is normal at the moment, repaired X11 session login loop but Wayland.

*Sorry if my English is not enough to clarify my case :slight_smile:

Ok, thus the first thing is that because you removed the entry in /etc/fstab, we still have no idea what it looked like. :frowning:

Second is about that “Windows’ partion password”. Do you mean the Windows file system (what type is it? VFAT, NTFS, …?) is protected by a password?

Or maybe you were asked for the root password?

I am afraid we need the exact message you got.

And you still did not answer what you mean with “connected to the home path”.

Second is about that “Windows’ partion password”. Do you mean the Windows file system (what type is it? VFAT, NTFS, …?) is protected by a password?

Windows partition is NTFS not crypted but just login password.

And you still did not answer what you mean with “connected to the home path”.

An advice was that to set windows partition mounting option into /home for auto mount and never ask root password again. After this config or KDE Wallet disabling had broken my session login as I said. At least, I think so.

I d not know where you found the “advice” to mount the Windows file system at /home, but it is a very bad one. You have already a /home that is populated with the home directories of your user(s). When you mount something over it, that will all become invisible and I doubt very much that is what you want.
It will make login of the user even impossible IMHO.

I still do not understand about that password, but as you removed the dangerous entry in /etc/fstab, we may probably forget that.

hehe :smiley:

now how can I repair wayland login loop? snapshots also could not fix.

I hope others will join here. I have no Wayland experience at all (just using X11 for ~30 years and it satisfies me).

Also I have no idea what you may have damaged with your strange action. I hope sincerely not much, but you never know what happened when trying to login and the software could not even find your home directory.

For the moment, just be glad you can work with X11.

And BTW, I doubt very much that KWallet disabling has anything to do with this.

1 Like

My suggestion to start with is to create a new user in the KDE Plasma X11 session, then logout, and try to start a Plasma Wayland session, logging in as the new user. Does that work?

If not review the following KDE troubleshooting guide.

Also, examine the journal output following an attempt to start a Plasma Wayland session…

sudo journalctl -b | egrep "kwin|plsma" > out.txt 

You can upload lengthy text using the susepaste command (you may need to install it first) using something like

susepaste -t "Debug _output" -e 87600 -f out.txt

then share the link that it generates here so that others can review.

For more info, refer ‘man susepaste’.

My suggestion to start with is to create a new user in the KDE Plasma X11 session, then logout, and try to start a Plasma Wayland session, logging in as the new user. Does that work?

Yeap, created a “test” user and logged in Wayland session successfully. It worked, so the issue looks related to my user.

susepaste did not give upload link, just stuck on terminal. then I searched the out.txt and uploaded by hand.

This is on X11

And this is on Wayland

Yes, a likely issue with a user configuration file. I can only speculate that it may down to ~/.config/kwinrc (but there is no direct evidence for that yet).

Unfortunately, the log you shared is incomplete, and both contain mostly overlapping output anyway. So, nothing definitive learned from these.

You could try the debugging step I linked to earlier, and upload the resulting ~/startplasma-wayland.log to susepaste for review. (The commands are run from a terminal eg VT4 as the user account under investigation.)

Unfortunately, the log you shared is incomplete,

I have no idea coz just pasted what it given to me directly.

You could try the debugging step I linked to earlier, and upload the resulting ~/startplasma-wayland.log to susepaste

I’m not sure what causes KWin to crash there, but perhaps try removing (or renaming) ~/.config/kwinrc for the user concerned, and then attempt to login as that user form your display manager login screen. Any different?

tried several times but did not help.

Hard to say what you did previously that caused this issue, but the pragmatic option may just to be backup the existing user’s ~/.config/ directory and default configs will be regenerated as required. Application-specific configs can also be copied back if needed for any customised settings. I can’t really offer any further advice around this, and clearly the Wayland session works as expected with the new user account.

any option to copy new user’s config for wayland to my daily user account. that can help?

You could use something like the following…

sudo cp -R /home/USER1/ /home/USER2/ && sudo chown -R USER2:users /home/USER2/

is this also okay for my x11 session? looks complete home folder changing.

Yes, you can do it from an X11 session, or do it at runlevel 3 (multi-user mode) from a VT.