openSUSE lässt sich nicht nach Installation booten

Als ich neulich von Ubuntu auf openSUSE zurück-/umsteigen wollte, ließ sich das System nach abgeschlossener Intallation nach einen Neustart nicht mehr booten. Auch das GRUB-Terminal brachte mich nicht weiter. Sicherheitshalber habe ich die Installation ein weiteres mal durchgeführt und um sicher zu gehen habe ich auch noch Mandriva ausprobiert, doch es trat das selbe Problem auf. Als ich dann in der Mandriva-Installation lilo als Bootmanager gewählt habe funktionierte der Bootvorgang einwandfrei. Da jedoch die openSUSE installation lilo nicht unterstüzt habe ich nach dem ersten Systemstart nach der Installation mitb GRUB lilo nachträglich installiert (openSUSE fährt den Computer nach der Installation nicht ganz runter sondern startet irgendwie direkt von der Festplatte). Nur jetzt habe ich das Problem, dass nun das grafische System nicht startet und zum anderen ich mich nicht im tty anmelden kann. Als erstes (also direkt nach dem Systemstart) spuckt openSUSE mitten im Feld für den Benutzernamen folgendes aus:

/usr/bin/stop_preload: line 7: /var/cache/preload/prepared.3128: Read-only filesystem
/usr/bin/stop_preload: line 11: /var/cache/preload/trace.gz Read-only filessystem

Ich habe die Nachricht zuerst durch die betätigung der Eingabe-Taste ignoriert und somit ein leeres Anmeldefeld angefordert doch nach diesem und allen weiteren Anmeldeversuchen sagte mir der PC:

[278.037387] type=1503 audit(1295883463.036:2):operation = "change_hat" info = "unconfined" error = -1 pid = 3137
[278.037387] type=1503 audit(1295883463.036:3):operation = "change_hat" info = "unconfined" error = -1 pid = 3137
Fehler im Service-Modul

Ich habe schon den fsck-Befehl über die openSUSE rescue-live propiert, erfolglos.

Die lilo.conf und die ftsab Datei wird bald nachgeliefert.

Hier die beiden versprochenen Dateien

/etc/fstab:

/dev/disk/by-id/ata-IC35L120AVV207-0_VNVD06G4C94BAL-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-IC35L120AVV207-0_VNVD06G4C94BAL-part2 /                    ext4       acl,user_xattr        1 1
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

/etc/lilo.conf

vga = normal
read-only
menu-scheme = Wg:kw:Wg:Wg

lba32
timeout = 80

image = /boot/vmlinuz
label = openSUSE
root = /dev/sda2
initrd = /boot/initrd

Ich kenn ich mit Lilo nicht aus, aber die Fehlermeldung von Preload sieht
danach aus, als würde dein Root-Dateisystem nur read-only gemounted.
Die Frage ist allerdings warum. In der fstab seh ich keinen Fehler.

Wild herumratend: Kann es sein, dass von Ubuntu noch irgendwelche Dateien/Verzeichnisse übrig geblieben sind? Hast Du die Root-Partition neu formatiert? Vielleicht können einfach nur ein paar Verzeichnisse und Dateien (nicht die ganze Partition) ja dann auch vom openSUSE-System nur gelesen und nicht ausgeführt werden werden. Denn Ubuntu hat doch als Standard den Benutzer Root deaktiviert (ein ungültiges Password für den Benutzer Root), oder?

Ich glaube, ich würde

  1. Sicherheitskopien machen,
  2. nochmal eine openSUSE CD möglichst bitgenau herunterladen und brennen
    (die sehr genaue Checksum SHA256 wird mit Firefox, DownThemAll! und Auswahl “Metalink” dort ganz automatisch überprüft, Überprüfung/Vergleich nach Brennen müssten auch die meisten Brennprogramme können und im Menü der CD/DVD ist ja auch noch eine eingebaute Integritätsüberprüfung)
  3. bei der Installation auch darauf achten, dass die Root-Partition neu formatiert wird (und Grub auch neu installiert wird).

Aber das ist - wie angedeutet - nur Herumgerate - vielleicht ist jemand anders schlauer?

Viel Glück
pistazienfresser

Einen Fehler beim Download und/oder beim Brennen kann schon einmal ausgeschlossen werden. Ich habe nämlich einmal die Installations-DVD und einmal die Installations-CD mit KDE heruntergeladen. Außerdem habe ich ja auch Mandriva probiert. Und bei der Installation habe ich immer die Festplatte formatiert. Auch habe ich den GRUB (bei GRUB habe ich nicht einmal den Kernel zum starten gebracht) und den LILO-Bootloader auf der Root-Partition (sda2) und auf dem MBR installiert. Eine Home-Partition habe ich nie erstellt. Ich probiere jetzt die Festplatte über eine Live zu formatieren.

Ich habe die Festplatte per live formatiert und openSUSE mit GRUB im MBR installiert. GRUB spuckt

Error 21

aus.
Wenn ich mal wieder Lust und Laune habe meinen Computer einzuschalten werde ich die /boot/grub/menu.lst und die /etc/default/grub Dateien posten.

Ist das boot flag (aktive Partition) gesetzt?
Hast du eine eigene /boot Partition?
Hast du eine oder mehrere Festplatten?
Wie schaut das Festplattenlayout allgemein aus?

Ich habe keine eigene /boot Partition, sondern nur eine Swap-Partition (hd0,0 / sda1) und eine Root-Partition (hd0,1 / sda2) in der sich auch das /boot Verzeichniss befindet. Auch benutze ich nur eine Festplatte. Ich habe auch über eine Live-CD GRUB über die GRUB-Konsole zu installieren. Ich habe als erstes sicherheitshalber noch einmal mit dem

find /boot/grub/stage1 

Befehl überprüft welche Partition die Boot-Partition ist. Es kam (hd0,1) raus.
Dann habe ich über

root (hd0,1)

die Partition als Boot-Partition gewählt.
Zum Schluss habe ich noch mit

setup (hd0)

den Bootloader auf dem MBR installiert.

Hier ist noch die /boot/grub/menu.lst Datei

# Modified by YaST2. Last modification on Di Jan 25 20:53:10 CET 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,1)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.3 - 2.6.34-12
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-IC35L120AVV207-0_VNVD06G4C94BAL-part2 resume=/dev/disk/by-id/ata-IC35L120AVV207-0_VNVD06G4C94BAL-part1 splash=silent quiet showopts vga=0x31a
    initrd /boot/initrd-2.6.34-12-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34-12
    root (hd0,1)
    kernel /boot/vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-IC35L120AVV207-0_VNVD06G4C94BAL-part2 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x31a
    initrd /boot/initrd-2.6.34-12-default

Hier die /etc/grub.conf Datei

setup --stage2=/boot/grub/stage2 --force-lba (hd0) (hd0,1)
quit

Ich habe in denen beiden Dateien keinen Fehler gefunfen.

Hier noch einmal die Meldungen von GRUB:

GRUB Loading stage1.5

GRUB loading, please wait...
Error 21

Ich werde mich einmal über Error 21 informieren.
Frage: Gibt es vielleicht eine Log-Datei zu GRUB? Wenn ja könnte man schon einmal sehen ob GRUB die Partitionen erkennen und erfolgreich beschreiben konnte, denn GRUB kann ja nur eine Log-Datei durch schreiben auf die Festplatte speichern.
Ich entschuldige mich schon einmal im vorraus für den s***** den ich gerade geschrieben habe.

vielleicht fehlt der / Partition das boot flag?
GRUB wird vom openSUSE Installer normalerweise problemlos in den MBR installiert.
Da muss im nachhinein nichts mehr nachinstalliert werden.

Bis auf Fedora 12 u. 13 hatte ich mit der GRUB Installation auch noch nie Probleme.

Ich habe jetzt noch einmal ganz von vorne gestartet, das BIOS resetet (man kann nie wissen) und ch habe openSUSE nocheinmal neu installiert. Diesmal habe ich eine eigene Boot-Partition, eine eigene Home-Partition, eine /-Partition und eine Swap-Partition erstellt. Jetzt komme ich wenigstens in die GRUB-Konsole. Nur wenn ich per

root (hd0,0)

versuche ihm die Boot-Partition zu vertickern, protestiert er mit einer Fehlermeldung. Da meiner Meinung nach das Problem an einer ungünstigen Hardware-Verteilung liegt probiere ich openSUSE entweder in der nächsten Version zu installieren oder sobald ich eine andere Festplatte in die Finger kriege. Ich würde ja gerne versuchen das Problem irgendwie zu lösen, da ich aber den Computer auch zum lernen für die Schule brauche werde ich wohl eine andere Distribution benutzen müssen. openSUSE werde ich auf jedenfall irgendwann doch installieren vielleicht in den nächsten Ferien, da ich mit SUSE schon vor zwei Jahren sehr gute Erfahrungen gemacht habe.

Sorry, ist das erste mal dass ich mich mit GRUB beschäftigen muss, was ist ein Boot-Flag. Ich habe die ganz normale Standard-Installation genommen außer, dass ich halt eine extra Home-Partition abgewählt habe. Den oberen Eintrag kann man vergessen, denn ich habe gerade Fedora ausprobiert. funzt auch nicht
Mandriva funktioniert nur mit lilo und außerdem mag ich Mandriva nicht und Ubuntu funktioniert mit GRUB aber Ubuntu will ich gerade los werden. (Ubuntu ist die reinste Apple-Nachmache meiner Meinung nach, und im Software-Center bietet Canonical jetzt schon automatisch Kommerzielle Produkte an)

Ubuntu verwendet GRUB (auch bekannt als GRUB 2) und openSUSE verwendet GRUB Legacy (auch bekannt als GRUB 1).

Nebenbei: GRUB 1.99~rc1 released.

Wenn bei dir GRUB 2 mit Ubuntu funktioniert, dann kannst du GRUB 2 auch für openSUSE verwenden.

Aber ich würde einmal folgendes probieren:

  1. MBR Komplett löschen (Achtung: dies löscht auch die Partitionstabelle!)
    dd if=/dev/zero of=/dev/sda bs=512 count=1

  2. openSUSE 11.3 ganz normal installieren, neue MSDOS Partitionstabelle anlegen und partitionieren.

  3. eigentlich sollte openSUSE danach starten…

Habe gerade den Boot-Flag per fdisk gesetzt. Boot-Flag war schon vorher gesetzt. Werde morgen die beiden anderen Methoden testen.

Das Boot-Flag wird vom openSUSE Installer automatisch gesetzt.

Im Installer lässt sich so einiges Einstelle.
Vielleicht funktioniert es, wenn GRUB aus dem MBR startet, anstatt von der Bootpartition.

Unter “Systemstart” können die GRUB Einstellungen angepasst werden.
http://www.abload.de/thumb/149va.png](http://www.abload.de/image.php?img=149va.png) http://www.abload.de/thumb/2gyxt.png](http://www.abload.de/image.php?img=2gyxt.png)

Tipp Nummer 1 ist leider fehlgeschlagen. Dafür hat Grub 2 funktioniert. Ich habe per Live Grub 2 auf den MBR installiert. Danach musste ich beim booten nur noch den Standort des Kernel und von Initrd angeben und schon hat alles geklappt. Viemals Danke

Super Problem gelöst!
Ich hoffe das GRUB2 in openSUSE 12 und Fedora 16 zum Standard Bootloader wird.
Dann hätten wieder alle großen Distributionen den selben Bootloader.

Siehe hierzu:
https://features.opensuse.org/308497

Beste Grüße
pistazienfresser

Hallo Leute,
ich habe genau das gleiche Problem:erst Ubuntu10.10 installiert, dann ersetzt durch Suse 11.3, danach kein boot mehr möglich. Dann habe ich verschiedene andere Versionen probiert, immer das selbe. Dann habe ich die Festplatte getauscht, komplett formatiert, Suse 11.3 installiert und - immer noch kein Boot möglich !! Das Problem ist offenbar nicht auf der Festplatte zu suchen. (!!) In der PC-Welt 2/2010 wird der Grub2 vorgestellt. Auf Seite 23 steht etwas über “Payload”, dass Grub2 nicht mehr den MBR verwendet, sondern sich direkt in den BIOS Chip schreibt. Vielleicht tut das Ubuntu? - Keine Ahnung, jedenfalls suche ich nun eine Möglichkeit, das BIOS neu einzuspielen. Vielleicht hilft diese Info weiter, bin gespannt. Übrigens: habe testweise WinXP installiert: das Zeugs bootet. Ich denke das wird man wegen den Bios Update brauchen. - Bin jetzt aber für 3 Tage weg, kann mich erst am Wochenende wieder damit befassen.

Hallo vinylschaber !

Was ist das denn?Hört sich ja übel an…
Habe selber bis vor kurzem ein Ubuntu “mit durchgefüttert”,ist jetzt aber gelöscht.Die nachfolgenden
openSUSE-Installationen gingen zum Glück glatt über die Bühne.
Habe im Tec-Channel dazu folgendes gefunden >http://http://www.tecchannel.de/server/linux/<:

GRUB 2 als Payload für Coreboot
Die aktuelle Version des Grand Unified Bootloader lässt sich ebenfalls als
so genannte Payload für die freie BIOS-Alternative Coreboot verwenden, das
früher unter dem Namen LinuxBIOS entwickelt wurde. Für diesen Fall verwendet
GRUB 2 nicht den MBR einer Festplatte, sondern schreibt sich direkt in den
BIOS-Chip des Systems. Coreboot initialisiert in diesem Fall die Hardware
und übergibt danach die Kontrolle an GRUB 2.

Aber sieht nicht so aus,als ob sich GRUB2 selbsttätig ins BIOS installiert,und dann nicht mehr zu
beseitigen wäre.Hätte ja bald was von der Windows-Tour,die Oberhoheit über die Festplatte für sich
zu beanspruchen!

Grüße !

lostinspace