OpenSUSE laptop can't run at full resolution with second 26" monitor

Hey all, I have an older Dell Latitude D810 laptop that I was running just fine with Debian 6. I tried OpenSUSE on a workstation and liked it so I installed it on my laptop. Now my laptop can no longer run at full resolution (1920x1200) on my second monitor, a Samsung 26" SyncMaster. When I try to go with full resolution I get a screen full of little boxes and I have to wait until it drops back down to a lower resolution before I can see anything. Is there a driver update or something else I can do to get my laptop to run that second monitor at full resolution? I don’t want to start a flame war or anything but I figured if Debian could do it OpenSUSE could do it too. Any help here would be greatly appreciated.


Joe B

After booting were you able to reconfigure the external monitor graphics with the terminal command ‘xrandr’ ?

Telling which graphic card you have would definitely help :slight_smile:

You don’t say which desktop you are using but if it is KDE AFAIK KWin will default to the lower resolution; a different graphics card won’t help. You can use KDE with other windows managers - so that would be the way I would go. Which windows manager were you using under Debian?

Assume you’re running the default nouveau driver, recommend you try the nVidia proprietary driver.

Add the nVidia repo as one of the officially listed Communities repo, do an update using YAST or zypper, reboot and try your monitor again.


→ oldcpu – I didn’t use the xrandr command. For one, I don’t know what it is or how to use it and for two, I used the Monitors utility under System > Preferences. I was able to make changes that way, but not up to 1920 x 1200.

→ arvidjaar – LOL, that’s a very good point. I found this by running lspci: VGA compatible controller: ATI Technologies Inc M24 1P [Radeon Mobility X600]

→ john_hudson – I’m running Gnome 2.30.2 right now on Debian (I went back to Debian so I could get up to full resolution). I’m not sure what version of Gnome I was using under OpenSUSE, the OpenSUSE version was v12.1.

Thanks for taking the time guys and/or gals,

Joe B

Hi tsu, sorry I missed you. My laptop has an ATI video chip in it.


Joe B

jbruyt, … if you are using kde desktop, then try this : boot laptop with external monitor not connected. After boot complete then plug in external monitor and type in a terminal / bash shell the command : xrandr

That may start a gui and the rest may be intuitive

Hi oldcpu, sorry but I’m not using KDE, I’m using Gnome.


Joe B

Nah, that would just throw back the default output of the xrandr command line utiltiy*

  • Self described as a “primitive command line interface to RandR extension” and which “If invoked without any option, it will dump the state of the outputs, showing the existing modes for each of them, with a ‘+’ after the preferred mode and a ‘*’ after the current mode.”

I could have sworn that, in the past, under KDE, krandrtray would open on the desktop, however, it seems it just populates in the system tray … from which you can easily click upon it to bring the GUI up on the desktop.
The command “kcmshell4 display”, on the otherhand, will indeed open the GUI upon the desktop.

Another nice little frontend GUI for randr is “arandr” (I believe its available in the default repos, if not, its available from OBS)


Thats not the case on my laptops with KDE and with Intel graphics and another with ATI graphics.

On those laptops, with KDE, if I first plug in an external monitor, and then in a terminal type ‘xrandr’ I obtain a GUI to tune with multiple monitors. This is contrary to your ‘Nah’. I think accuracy important here.

xrandr - primitive command line interface to RandR extension

It is possible that on your system something else is installed or xrandr is aliased to something else, but xrandr is really what it is - command line utility. No GUI. Could you check with “rpm -qf $(which xrandr)” to which package it belongs?

and indeed on my desktop PCs, if I type ‘xrandr’ I do get a primative command line shell. But as I noted, with ATI graphics and KDE on a Laptop, and with Intel graphics and KDE on a Laptop, if I first plug in the external monitor, and type ‘xrandr’ in a bash shell, I obtain a KDE GUI to configure the second monitor.

I have a how-to-post on this that I wrote some time back, and as of openSUSE-12.1 and KDE the behaviour has not changed. I have not tested this yet with 12.2 and KDE

Speaking of accuracy, when I went to look at some old posts, I note I quoted ‘xrandr -q’ as the command I sent and not just ‘xrandr’. I could of sworn (and been wrong ??? ) that I only typed ‘xrandr’ and had this work so I need to check again myself. < sigh > … So it could be me being inaccurate here.

Anyway, to see what the GUI can look like, here is an old thread: Take a look at post #11 and #12. I note I obtain similar gui’s for both Intel and ATI hardware, but best I have read the same is not true for nVidia hardware.

… and as noted, I need to double check my work as I could be wrong about only ‘xrandr’ and maybe one needs to type ‘xrandr -q’ …