Opensuse ISO size different from size reported by k3b

I’ve noticed that the size of the downloaded ISO and the size reported by k3b and imgburn (windows 7) are different. Is this normal? If so, why?

-iso size 4,648,337,408
-k3b / imgburn size 4,647,323,648

If I extract the iso from the dvd using any program, the extracted iso will be the same size as the original downloaded iso (the hash also matches). The incorrect size is only seen in k3b and imgburn. This size difference also happens with Fedora. This size difference doesn’t happen with Ubuntu, Manjaro, or Linux Mint (the k3b size is the same as the iso size).

I tried burning with Brasero and k3b in Ubuntu 16.04.1 and Opensuse Leap. I tried using different computers, burning at 1x speed, and using DVDs with different manufacturer codes. The results are always the same as above.

I’m not sure I understand you
what is the sha256 of the LEAP iso you have

>sha256sum /path/to/leap.iso

according to
teh sha256 is 8576e84822cdbe566bf551e28a169fc028229831eba9f07a4c1f84302c5ddb09
there are several reasons your sha256 might be different
your download got partially corrupted ( a single bit will change the SHA256), the mirror you got it from added some garbage (this happens often) and modified the SHA256, you used a download manager that reallocated a few more bytes, you have a hardware issue.
the LEAP 42.1 iso hasn’t changed in 10 months neather has the SHA256

Thank you for the reply, I_A.

Sorry I did not explain well. My sha256 sum is not different from what is listed on the website. The sha256 of my downloaded ISO is
The size of this ISO is
4,648,337,408 bytes

The only thing that is different is the file size when I look at the disk info after burning Opensuse to a dvd. Imgburn and k3b both report the burned disk as:
4,647,323,648 bytes
Specifically k3b reports:
Volume size: 4.3GiB (2,048 B * 2,269,201 blocks = 4,647,323,648 B)

If I extract the iso from this disk, the extracted iso will once again match the original downloaded iso as follows:
-sha256 8576e84822cdbe566bf551e28a169fc028229831eba9f07a4c1f84302c5ddb09
-4,648,337,408 bytes

I am wondering why this difference in file size exists between the ISO file and the disk info reported by k3b.

You burn that ISO as ISO, not as data?

k3b------Extra----ISO burning (I am here on German, maybe it is another menu).

Thank you for the reply Sauerland. Yes, I burned as ISO, not as a data disk.

Block size…

there are several reasons for a different hash
you used short lead-in, or you did not finalize the iso, or there wore burn errors, maybe there was some data on the disk…
optical disks are prone to errors and the udf file system (which I assume opensuse uses) has extra recovery features.
I’d say boot that dvd and run the medium test, if it passes think nothing off the different hash.
that hash is important for downloads as users can check the iso and be sure nobody messed with the installer (something that happened to mint a few months back)