Opensuse isn't for my laptop


I have a dell inspiron 15R (5520) laptop some 3 months old now. It came preinstalled with ubuntu 11.10. Uninstalled it right away since I have been using opensuse from some time now. my laptop had serious issues with display on 12.1 and so I decided to wait for 12.2. I installed 12.2 and was delighted to see everything in order on my screen. Since I have my system ready to go I went ahead bought a wireless adapter and I found out that the broadcom wireless adapter is not supported. So is my bluetooth. I posted about the issue on the forum and came to know there is no driver for the card. I found a work around (only for wifi not bluetooth). That fixed my wireless. After that I ran an online update and then on the x server wouldn’t start. So I did another fresh install. My plan was to do all the updates I need and then apply the fix for wireless (if the wireless workaround was doing some change to my kernel then I could avoid any issues while I ran the update). I installed 12.2 followed by google chrome and amd catalyst driver and the usual online update. Now my system boots and gets stuck somewhere. Plymouth is fine but the whole process never reaches the login screen. I could hit alt+F5 and login to command line but ‘startx’ didn’t work again. So I tried upgrading from the boot dvd hoping I could keep all the changes that I made. Finally, that made even grub to delete windows from the list… Got rid of all and I have installed opensuse with a minimal text only interface and left it there since I didn’t know how to install grub alone .I have been using a windows 7 for the past few months because I could not get any linux to run on my hardware I can’t afford to lose that windows. Also the system heats up a lot and the fan seems to be screaming away. Battery doesn’t last longer than an hour and a half.

Developers please note this and consider it a priority because as I understand this is a pretty new hardware (ie. intel 3rd gen, radeon hd 7xxx series graphics card, broadcom 4365 series wireless card etc etc) and as far as I have read on different forums all owners have issue with wireless, bluetooth and system heating up.

If at you think my system could be fixed please note that I have only a minimal text interface in case you want me to run any diagnostics on my system.

On 09/17/2012 05:06 PM, melvinjose wrote:
> If at you think my system could be fixed

Rule One: Use what works.

therefore, i suggest you reinstall Ubuntu 11.10 and run it as your daily
driver and from time to time (when new stuff is available) boot from and
run Live CD from various distros until you find something newer which
works well with your hardware…

and remember, newer kernels and code may or may not be sweet on your

i have no idea what Ubuntu 11.10 had/has, but it may be the most
advanced version you can run. (did/does Dell recommend you upgrade to a
newer Ubuntu, or . . . ??)


In that case Everybody would have used only windows on their personal computers (It works and works very well). If I had to switch between distros then I wouldn’t have posted it here. I don’t use linux for fun, I use it for doing my work and there are features in opensuse which aren’t there in ubuntu. I like and use this distro for those features. One among them is Yast. I can’t find that on ubuntu or any other distro for that sake.

I don’t think it was any good. All ubuntus have backward compatibility. the touchpad had frozen with 11.10 and I couldn’t use it anymore… I had installed 12.04 and even that had the same issue except the booting problem. Initially even opensuse didn’t have any booting issue untill the online update.

Did you reinstall your video drivers?? Should be done after a kernel update. Better then reinstall the OS LOL

On 09/17/2012 08:06 PM, melvinjose wrote:
> In that case Everybody would have used only windows on their personal
> computers.

for me Win3.1 didn’t work, so i dropped Windows and got a secure,
multi-threading OS.


On 2012-09-17 17:06, melvinjose wrote:
> Hi,
> I have a dell inspiron 15R (5520) laptop some 3 months old now.

I never buy the most recent hardware for use with Linux. And I try to learn before buying if it will

> Developers please note this and consider it a priority because as I

Unfortunately very few devs read here.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” (Minas Tirith))

IMO, it would have made more sense for a 3 months old laptop to come with Ubuntu 12.04 (LTS) preinstalled.

It’s impossible to help you without knowing which fix you applied.

What do you mean by “the usual online update”?

But if I remember correctly, you were using the OS/2 Windows emulation at this time - which worked better than Windows … :wink:

I just can’t figure my way out on the command line. I’m sorry…I come from windows and the only option I knew was to reinstall the OS

I have provided a link to the other thread. its this

And as for the ‘the usual online update’. Its the one that I can run from Yast. Open up yast, in the first section there is an icon ‘online update’. Thats the one I ran. If I’m right thats the one that opensuse recommends and shouldn’t it be safe?

And Yes I applied this fix. F17 Broadcom 14e4:4365 Dell Wifi 1704 Drivers - Nobody in the wireless forum explained what it does. I think it does fiddle with the kernel as far as I have understood.

I did update yesterday and I still have my GUI. So it is at least not generally unsafe :slight_smile: Where have you got your catalist drivers from? Was it from openSUSE (or for openSUSE) repository or did you use some other method? In this case, which one?

Nobody in the wireless forum explained what it does.
This simply compiles and installs additional driver. It does not interfere with the rest of your kernel. If you update kernel, this driver will likely stop to work and you will need to reapply the same procedure to new kernel version, but it is highly unlikely it did something to your existing kernel installation.

Downloaded the binary file from amd. I think it would have been safe to do the one-click installation from opensuse, right?

Thanks a lot. Thats all I wanted to know. I’ll probably do a fresh install and do an online update first. Then install the catalyst driver(from opensuse) and load the new drivers for wifi. And If i’m right my bluetooth is connected to the wifi adapter by some usb interface (is that possible??) I’m not sure (They are both controlled by the same switch/button[F2]). If by any chance I’m right, getting my wifi working should also enable bluetooth, isn’t it? Or is there something more i need to do for that?

Any solution to system over heating? I had read quite a bit through the forum on AHCI (i guess) and it was all Egyptian and Mesopotamian (far from greek and latin :D) .

Using atiupgrade would have been better … however it’s not perfect on 12.2, but still better than downloading the wrong driver or not installing the right devel package for your kernel. atiupgrade takes care of that … and it might also have solved some of the other problems you had if it was about compiling kernel modules.

You can install atiupgrade from my repo, as described in this article (use the 12.2 repo): ATI driver with atiupgrade (new version)