OpenSUSE is like SUSE 8 years ago

Yesterday I just installed OpenSUSE 11.1 after being completely frustrated with Ubuntu 9.04. The installation worked kind of well and after some time I had a much faster Linux Desktop. Much more reactive and with a nicely integrated KDE. These were the nice things.

But I also experienced negative things:

  • a very confusing GUI bug in a very early stage of the installation program
  • very clunky DSL setup procedure (it took me 30 minutes to make it really work completely)
  • ugly fonts
  • spell check is in english although I did setup a German system
  • mounting of partitions - which could be done quite easy in Dolphin - only allowed by root. why?? this is a desktop system and no multi-user terminal… that makes me spend more time as root which is not really secure. (A regular user would start Dolphin in admin mode - ironically both windows look the same. Who knows what SUSE users already did to their desktops by forgetting that Dolphin is running in admin mode…)
  • when you install gcc-4.3 the executable is called gcc-4.3 and there is no executable gcc. What’s the point of doing this?? Everybody using the gcc would make a symbolic link to gcc anyway so why does yast not?

And last but not least: The kernel headers are installed in /usr/include. Why? This makes no sense in two ways:

  1. When I look at the gcc issue it seems to me the SUSE philosophy is to enable a lot of customization to the user e.g. by allowing him to easily maintain multiple versions of a tool that is nasty to install.
  2. On the other hand it is “standard” on Linux that kernel headers are installed in /usr/src/kernel-header-xxx or something. Really this makes no sense.

Why bother? I’m currently installing VMWare and it needs to compile it’s kernel modules. Well you might say: Why don’t you make a symbolic link? Doesn’t work. Of course I could download the headers. (Haha, this is a SUSE patched version… Maybe I should compile a custom kernel. I bet that I then run in more problems than before…)

Sorry guys but SUSE is as administration-hostile and heavy-weight as it used to be. Of course the latter won’t matter if it all worked - but it doesn’t.

And all these tiny issues. They are often to fix. But hey, I’m here to actually use the software on my Distro and not to administrate my Distro the whole time. Ubuntu is in some regards technically inferior in particular in the things regarding hardware, partitioning etc. But at least it doesn’t have all these issues that also used to annoy me when I stopped using SUSE around 6 years ago.

And this can not be explained only by the fact that Ubuntu has a larger user base and more developers. These are issues that are visible the whole time.

Have fun with using SUSE… I’ll check out Fedora or something…

  • ps261 wrote, On 09/29/2009 01:06 PM:

> Have fun with using SUSE… I’ll check out Fedora or something…

Well, what can I say? Good luck, and thanks for the feedback.


> Have fun with using SUSE… I’ll check out Fedora or something…

good plan, see you!


You don’t really seem to care. If I was the maintainer of a distribution I would consider these things as bugs. When I started out using Linux which was a bit more that 10 years ago it was normal that a lot of things didn’t work, were annoying and occasional repair works that took long hours or even days.

But today? Life is too short to fix your system the whole day - except you are genuinely interested in that but then I don’t understand why you’re not using Arch Linux or Gentoo. In my opinion SUSE is still in the Linux Stone Age.

which gcc

rpm -qf /usr/bin/gcc

So much for that theory.

With over 10 years of Linux experience you should know the difference of headers being used for (almost all) user space programs (which reside in /usr/include where they belong) and headers used for building kernel modules (which reside in the kernel tree).

Next time, do your homework before trolling, you obviously don’t have a clue what you are “complaining” about.

Ok… I had to install the package gcc. Didn’t see it, just saw the packages with version numbers (e.g. gcc-3.3) on it.

I sometimes wonder who would install OpenSUSE without gcc. <:)

Thanks for your complaining. So what is your solution to my problem? Or to be concrete: What is the SUSE way to install VMWare? (Never mind… I just installed the kernel sources from the package manager. Still… orthogonal or elegant is IMHO something else…)

FYI: This is how SUSE deals with the linux-kernel-headers rpm:

linux-kernel-headers-2.6.27-2.28 - Linux Kernel Headers


No, this is a very efficient way of keeping headers for user space seperate from headers needed for kernel modules, giving you a safe way of upgrading your kernel to a new version and building modules against the new headers without changing the headers being used for a lot of user space programs.

Well, I know that, but FYI; rpm has two nice switches, “-q” and “-i”, try using them on that package.


You know that i.e. debian does exactly the same thing by providing the user space headers in another package than the kernel headers used for module compilation?

Debian – Details of package linux-libc-dev in lenny

Depends on the purpose of the machine, I would not install any compiler tools on a productive server for a start (no matter which distro). If one is using only supported packages (RPMs from official sources), there is no need for any development tools to get a running system (which certainly also applies to any decent distro with binary packages).

> I sometimes wonder who would install OpenSUSE without gcc. <:)

just all the people who wouldn’t know a gcc if it bit them, and have
no intention to ever compile anything…


ps261 wrote:
> You don’t really seem to care. If I was the maintainer of a distribution
> I would consider these things as bugs.

maintainer? none of those around here!! this is a forum of
users…volunteering to help other users get started with openSUSE…

did you think you were logging comments for maintainers? developers?
hackers? coders? well, you didn’t do your homework before you opened
wide your mouth and showed how smart you are…did you?

if your post was intended to be a bug report, i wonder in which distro
you learned to make bug reports to a user forum???

try again at:

wanna log your problems directly with the maintainers? i think some
hang out around somewhere near:
(but, i’m not sure since when i find a bug i use the system set up
for that purpose…long, rambling, non-specific whine about a wide
variety of stuff is always as useful to a hacker as it might be to you…

> In my opinion SUSE is still in the Linux Stone Age.

sir, your opinion is highly valued and since i’m looking for a better
distro i’ll be checking out Fedora, or Gentoo or Arch…or one of the
other of the hundreds…

now, why don’t run along too! btw, is your middle name troll?