OpenSuse is gone from my bootloader suddenly and I only see Windows on the dual boot menu

I’m not quite sure why this suddenly happened. I’m on Tumbleweed 42.3 and Windows 10. What are some steps I can do to diagnose the issue?

There’s no tumbleweed 42.3. Do you mean leap 42.3 or tumbleweed?. Are you using a tweaked windows bootloader or grub2?

Right I meant leap 42.3. I’m using grub2. The windows bootloader shows up as an option

Try this in a terminal

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Or you can see what is showing in Yast2>System>Boot Loader. Check all 3 tabs along the top. It’s self explanatory.

I can only boot up windows at the moment though. What I tried to get a terminal up was, I tried burning the iso onto a usb but the options there is only rescue mode (which seems to just shut off my display) and reinstallation which would be a last resort. Would you know where I can get the live usb version of openSuse? (I had followed the steps here https://en.opensuse.org/SDB:Live_USB_stick)

Do you mean the rescue mode does not give you a command line prompt? Or, does it.

Basically, you need to boot with an openSUSE rescue disk (the installer will do that) and log into the command line as root (no password required). You would then need to chroot to the installed system, possibly remake and reinstall Grub.

But, first, if you can get into the command line rescue system, or can boot with any Linux boot disk, the output for:

fdisk -l

and

parted -l

might reveal an even simpler solution.

Did you install EUFI, or Legacy?

… BTW, what probably happened is a Windows update wrote over the bootloader code, which I guess was installed in the MBR? Or, if legacy with MS-DOS partitioning, the boot flag was moved.

three ways.

  • If you installed as uefi (is there an “efi” partition in the disk, or similar fat around 512 Mb partition with name like “boot” or “efi” (see it in windows, right clic the menu and choose disk management), then the boot order is done in the UEFI firmware

  • if you installed as legacy/csm, it’s probably the boot flag that was moved, search “boot flag” in windows to find how to put it again on the openSUSE partition.

all this have a meaning if you have direct boot in windows.

  • If you still see the grub boot menu, you can still boot openSUSE using the grub2 console mode, but it’s a bit tricky. On summary, you have to type “c” on the boot menu to go to console, them type “configfile”, then use tab completion to find what disk is used by openSUSE, then find the grub.conf file in /boot/grub2, search the web for details

jdd