Opensuse installing codecs the right way

IMHO it is very simple. When one uses Tumbleweed, one gets a new snapshot (rather frequently). A snapshot is tested as a complete collection of software and it is more or less a new distribution. That is why one does a zypper dist-upgrade (or zupper dup for short) to get that complete and tested collection. And when you understand the phrase about “tested as a collection”, you might understand why it is not a good idea to take only some of it and keep the rest as it is.

Best is to do the zypper dup say once a week (there are people that do it every day, just what you like).

That advice is there from the start of Tumbleweed and I have seen it passing by here dozens of time.

And when that applet or Discover or anything else based on PackageKit irritates you, switch it off, remove it, or simply forget it. You can use YaST for installing and removing packages to your liking, but not for updating.

And when this is not what you like, you may look into Leap, where things are different.


got it, thank you again for the explanation.
On Thumbleweed and Opensuse in general I notice different philosophy of doing things and even though it’s anyong at first, I like learning new ways in new distros.

It is always better not to assume that Linux distributions are the same. After all, when they are the same, then why different distributions?

So enjoy.

And please note that correct spelling is important in every computer operating system. That is of course true for spelling commands, but also other words are better spelled correct if you want to bring your message, or show that you understand what you are talking about. It is Tumbleweed and openSUSE.

I am using the help of this website for years in order to install the multimedia codecs:

(easy to find with google: opensuse multimedia - Google Suche )

Better use the more accurate and up to date SDB as already mentioned in the second comment of this thread.

How about this one (listed at the official opensuse website):

Nope. Don’t use and advertise 1-click installations! You can search the forum yourself how easily they will break your system…

Additionally this page is also outdated as it as example still recommends ffmpeg-3 for Tumbleweed (you have to inspect the links to see that…). We are already at ffmpeg-6 in Tumbleweed…
The same outdated libavdevice58 is recommended whilst we are already at libavdevice60…

1 Like

I understand but my problem was that I didn’t know that I had to install codecs.
In all the distros that I tried I never ever installed codecs manually. Only in Windows back in the 2000’s
And I couldn’t make the connection, because some movies were working with some glitches, some didn’t at all.

flow it is all good. My last two posts where directed at felbre who tried to advertise pages with outdated informations regarding the installation of codecs.

1 Like

I’m new on openSUSE. Codec was my concern when decided to hop into openSUSE.
In my journey to trying openSUSE, I found many tutorial suggestions about how to install codec via packman.
And I found the one stop tool that can help to install codec.
“OBS Package Installer” [1] [2]

Just run the command suggestion for the help menu,

$ opi codecs

Then, opi will working for us.

[1] SDB:OBS Package Installer - openSUSE Wiki
[2] GitHub - openSUSE/opi: OBS Package Installer (CLI)

I never used it, but it indeed seems to do the vendor switch in one command.

But I assume it must be run “as root” (your prompt does not show that).

Oh sorry, forgot to include those information.
It will prompt the sudo after another confirmation prompt. like this,

So, It can bring a sudo prefix into opi command, or not (I guess).

And again: The SDB which mentions how to properly install codecs from packman via opi or zypper where already mentioned in the first comment in this thread by Sauerland.


OK, I did not know that opi uses sudo when it is run as normal user (I assume that when you do as root, it will not do that).

I would never have thought about running opi as normal user when I want to work on the system.

When I would have done this as normal user by incident and then had got that sudo prompt, I probably would have killed it, to do it again as root.

I never use sudo, but that is a very personal attitude.

1 Like