Opensuse Installer will not run

Ok so I built a PC in August and I just upgraded my PC with another ssd so I have more space but when i try to install Linux it will not work. I tried opensuse leap 15 and opensuse tumbleweed.
When I boot the USB on start-up it will go to the install/upgrade/other thing screen. When I press the enter key it will start trying to run it will start doing stuff but every time it gets to
“starting udev” it crashes or for the tumble weed installer it will do nothing then after a bit it will reboot my PC. I reinstalled the ISO file and it it still does not work. I did get Opensuse “installed”
on this PC one time but when i tried to boot i got this “[FONT=Whitney]AMD-Vi: Completion-Wait loop”[/FONT][FONT=Whitney] timed out and in there there will be a few [/FONT] [FONT=Whitney]"AMD-Vi: Event logged ".[/FONT] [FONT=Whitney]
[/FONT]My PC parts are, anything else you would have to ask about for idk what else would be useful to know. and tell me if i should get a older version of opensuse or something
[FONT=inherit][FONT=inherit][FONT=inherit]CPU: Ryzen 3 2200g
GPU: gigabyte G1 geforce gtx 1060
Ram: 16gb of HyperX 3000mhz predator RAM (2 8gb sticks)
MB: gigabyte ga-ab350-gaming 3 Storage, M.2 crucial 500mx and a 250gb 2.5 form factor crucial ssd
[/FONT][/FONT][/FONT][FONT=inherit][FONT=inherit][FONT=inherit]500w EVGA psu
[/FONT][/FONT][/FONT][FONT=inherit][FONT=inherit][FONT=inherit]case: thermaltake veiw 31
Mouse: Logictech G502
Head set: razer man O war
KB: a old hp one
Internet is my ethernet


I don’t have any helpful advice. I’ll just point out that there seems to be a hardware incompatibility problem.

Should I try to disable my GPU and use the integrated graphics? Would trying a older Linux work? One guy said i should try opensuse factory or something

Try removing NVIDIA card and use the on board GPU at least to test.

In any case if NVIDIA is installed then the on board GPU should be disabled in the BIOS/UEFI. Having two incompatible GPU active could be the problem maybe.

Be sure secure boot is off and any fast boot settings in the UEFI also

My GPU is the problem i installed it but i had to disable it, what would i do to make it run with my GPU running? Do i need a kernal update? What ever it is make it a step by step thing so i do not mess up

Tried to put nomodeset?

Turn off the GPU on the CPU chip. Unless you have special Optimus hardware you can not run AMD and NVIDIA at the same time

I have the CPU graphics turned off most of the time, it will not work with the integrated graphics are Off or on auto, it will work when i set it to Forced. I never really turned off my GPU i think

You have two GPUs one on the CPU chip and one on video card. To use the NVIDIA on the card you must turn off the AMD one on the CPU. Can’t tell you how since BIOS/UEFI implementations are different. Consult the DOCs for your MB

You may need to boot initially with nomodeset kernel option until you install the NVIDIA drivers.Ask if you need instructions

I did turn off the AMD one, linux does not boot with it on, what is the nomodeset thing?

Assuming you get to the grub boot screen press e find line starting linux or linuxefi go to end of that line (it wraps) add a space and nomodeset this will use default drivers (note they have low res and are just for initial setup in this case)

If you don’t get a menu with the installer. It is possible you created the install media wrong. It must be a binary none changed copy of the ISO to the device (NOT a partition on the device)

I mean it does not like to boot with the nvidia card… hope i did not confuse yo

Well boot is a large process exactly where in the boot cycle does it fail?? Sure you got all the power connection on the NVIDA some cards require additional power connection.

If you remove the NVIDIA and turn on the MAD GPU does it boot??

Ok so i added it to the end with my GPU on and it does not work, I will get back to you on the boot part and where it fails

My GPU is getting the power it needs

How did you create the install medium?
Did you verify the download’s sha256 sum. or md5?

I downloaded off the download web page the newest one (unless you changed it in the last few days) i installed it to a flash drive using Rufus 3.something it is not the newest version.

Being an assembled the Gpu works only if you connect the motherboard cable to the monitor, if you connect the cable to Nvidia will work the Nvidia … or am I wrong? When you start the installation and you have in front of the screen where there is F1> help> F2 Language> F3 Video mode etc. I believe in F6 or F5 now I do not remember … asks you for the Boot options check nomodeset and proceed so see if it goes , so see if it goes or try safe mode

When i use my GPU I do plug the VGA cable to the GPU when i use the integrated graphics i plug the monitor to the MB, it does not give a imageif i don’t

Refus may make changes to the ISO image. It may have a dd or binary copy option that might work. Many Linux distro need help to boot from USB device openSUSE does not. Only thing that works is an unaltered binary copy to the device. Not a partition on the device, the device. If creating from windows a good program is

If from Linux use dd or even cp to copy the iso to the device .