openSUSE installer says I'm out of space

I tried to install suse 11.4 from live usb when it was installing, it said at one point that there is 0 b available on my disk. It’s impossible because I had a partition with 15 GB of space devoted to this installation. My hard drive is 300GB, 100mb for system reserved, about 50 + 214 for windows and the fourth partition is extended 35 GB. The extended 35 has 20 GB for FAT 32 and then 15 GB for the suse. And it said there is no room. I pressed explore or something from the error message and then the whole computer froze. I had to reboot and the grub was ofc fcked up, nice. So, atm I am running from another live cd. When I tried to boot the openSUSE live usb the usb was ruined… I don’t know what had happened but it tried to load the live usb, it had it’s cameleon picture and then error messages that said something about the usb being read only.

So, do you have any ideas what might have happened, why did it say there is no room when there clearly was?

You allowed only 15Gb for openSUSE! :open_mouth:

That is tight. You need at least :

  • 10Gb for the /
  • 10Gb+ for the /home
  • Depending on how much RAM you have, you need at least 1 to 1.5 x RAM. So, with 2GB of RAM, you need at least 2GB of swap and better if you have 3-4Gb.

Why do I need 10 GB for “/” and 10GB for “/home”? I don’t have any files in home dir when I install the thing. I am installing from live cd that is under 700mb. It would never fill up over 20 GB on the disk. I didn’t do any swap room because I have 4 GB of ram and I have never needed to use swap.

My fdisk info:

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xba228230

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13        6375    51097600    7  HPFS/NTFS
/dev/sda3            6375       34345   224668672    7  HPFS/NTFS
/dev/sda4           34345       38914    36700161    5  Extended
/dev/sda5           34345       36776    19529728    b  W95 FAT32
/dev/sda6           36776       38914    17169408   83  Linux

You are just using one partition then root and home all in one, that’s fine and it should work.
I never tried without swap

Are you going to the custom partitioning and managing it all from there?

I don’t remember. There was three options, one was customize and other was create or smth? I think I chose the create…

This route

If you really chose to have 15GB, that should be enough by far, also enough to fill a couple of homedirs with default settings etc.

I believe I chose create partition setup. I just looked what the customise is but I think I did the create thing. What is the differance if I chose one or the other?

If you want a special setup, which in this case you do, you need to use the expert/customize selection and specify exactly how you want things setup.

Also how much memory do you have?
And you really should have a swap partition even unless you really know you don’t need one.

I have 4 GB of RAM… as said before.

This really isn’t that difficult but you need some basic understanding

Ok, I got openSUSE installed. I downloaded the gnome 3 live CD, wrote it on USB and it worked. This time I made a 2 GB swap partition also. I have no idea if it was the thing that was needed before but it worked.

Now, I have new problems. My screen brightness is really low. From the gnome settings, it shows that the brightness is full and my keyboard shortcut also shows it’s full but it actually is really dim so it’s hard to see text on the screen. Also, the mousepad clicking function doesn’t work. I can click on the button but clicking on the… how to call it… on the “pad” itself doesn’t work. I am really used to clicking on the pad itself and not using the buttons. What can I do to resolve these problems?

I have some… Intel integrated craphics-****-card. Mobile 4 family or smth.
The laptop itself is Samsung R410 plus.

I suggest here that we help you through the new threads you started on this new subject/problem : LCD brightness is really low