openSUSE installation problems on HP/Compaq Machines??

I have tried to boot from openSUSE 11.1 CD/DVD on Compaq Evo D510 desktop as well as HP Pavilion DV6700 Laptop several times. Goes through everything for a long time. Ends up in a screen with colored stripes on the desktop and a blank dark screen on the laptop. I do see the wireless light on the laptop turn blue from orange indicating it is enabled. But was of no use. Both machines crash at the end. I tried both GNOME and KDE…both crash

I am suspecting the display drivers. The desktop has a Intel Chipset and the laptop GForce 8600 I guess…

Any ideas how to get it going? I had no problems on both with Ubuntu.

did you finish the installation or did it fail even before installation.
try booting with acpi=off and edd=off seperately.

Ow…even before installation. Wanted to try it out before installing.

By the way how do you set those parameters??

while in the boot screen.just type those parameters and you will see them at the bottom of the screen.
or just select safe mode and see if it works.

@nasrun -

Yes, often with video the drivers must be installed after the OS. How that is done depends on the particular device/driver. I got the impression from your post that you not installed, but you tried the LiveCD and the DVD - how did you try the DVD without actually installing? If you describe completely what you did and what happened - separately for each machine - then we can probably aid you to get it working.

Yes, in both cases I used the Live CD…The initial screens went as they should but eventually…the system just hung on a blank or a striped screen.

No I did not install the OS in both cases.

have you tried with acpi=off??

I tried…but jumps off to another screen…


jumps off to where exactly??

I have a similar problem when trying to install openSUSE on a Compaq Evo machine.
I used the dvd to install openSUSE and everything works fine untill the moment that the installation will configure the devices. I got a message like: “do not panic, your screen will flicker in order to configure your graphics card”.
After that flickering part, I get only blue and green stripes on my screen for hours and nothing happends.
Tried the commands suggested before, but couldn’t figure out how to run these.

Any idea how to solve this?

It would be much better for you to open your own new thread. That will provide your problem better visibility, and as a result faster and more response. In that thread you should indicate your computer’s specifications, in particular the video device (which may be integrated with the chipset or may be a separate discreet device).

As a quick reply . . . Usually this is because you need a proprietary video driver installed, which can only be done after completing the full OS installation. The method varies depending on the driver. Try installing using the “vesa” or “text” options (IIRC under F3). After the installation is complete (not at the mid-point reboot), at the boot menu type the numeral “3” (w/o quotes) in Boot Options. That will boot you to a command line prompt, login as your user. Then do:

su -
sax2 -r -m 0=vesa

If this doesn’t work, start your new thread including what you have tried, along with the specs.