OpenSuSE installation on Raid 0

Hey there. I got stuck in a weird situation. First of all, here are my specs.

CPU: AMD am2 64 -bit
Raid Controler Card PCI-E : RocketRaid3120 True hardware.
HDD: 2x 320GB Seagate SATA2, configured as Raid0, Stripping.
HDD: 1 x 750 SATA2 Connected to the motherboards’ sata2 port, used for backup.

The problem: So i start the installation of openSuSE 11, no problems, Raid gets recognized, i leave the default partitions provided by opensuse, which are.
2gb for swap, 20gb for / (root), and the rest which is about 500gb is left for /home.
So sda= SCSI Harddrive (Raid0 Setup)
sda1= 2 gb swap
sda2= 20gb as / (ext3)
sda3= 530gb as /home (ext3)

Then i start the install process, so then the partitions are created, and:

sda1 gets formated as swap
sda2 gets formated as /

but when it gets to sda3 this is what happens:

Formatting sda3 as /home with ext3

_____________17% and that’s where it stops.

So while formating the /home partition with ext3, it stops at 17%. Then there is nothing i can do, everything is frozen.
Now if i change it from ext3 to xfs it will format all the way, but when it comes to copying the X11 images(4) it stalls again at about 84%.

I thought there was something wrong with the setup, so i formated raid0 with fdisk from a floppy disk, and it never stalled, it formated all the way trough, so it only stops when formating the /home partition for openSuSE.
And also i installed openSUSE 11 onto an IDE hdd, so there is nothing wrong with the DVD (instalation source).

Did anyone come across anything like this before? Any suggestions on how would i go about getting past this?
Any help would be greatly appreciated.

Many thanks.


You might try formatting from a Live-CD which has a =>2.6.24 kernel, from the command line. mke2fs might give you a message that hints at the issue (or, it might just work). (You probably already know that its debatable whether you’ll get a performance advantage with this card compared to using the kernel’s md driver, given that the card is not full-hardware RAID and sits on the pci bus?)

Thank you for your reply. I haven’t tried formating from a live cd, but i went into Rescue System. Then used mkfs.
I did an export MKE2FS_SYNC=10 first. Then mkfs -t ext3 /dev/sda,which was all good until it got to the “writing inode table: 3820/4768” and that’s where it froze on me.

And alos as i mentioned before if i use XFS it works just fine, until i get to the part where it copies the X11 images, right after formating. So while copying x11 images it stalls again. Any ideas?

Thanks you

What about making /home smaller? You have it extremely large. It you’re thinking about a lot of space for say, music files, it’s actually much better to put that on its own partition. (My collection is on 3 partitions for better manageability.) This is only a guess, but perhaps ext3 is choking on such a large RAID0 filesystem. It could also be a quirk in the sata_promise driver vis-a-vis ext3 and this size.

Re the “X11 images” failing. I’m not sure I understand what you mean. If you are referring to the installation images that get loaded, those aren’t X but are compressed package installation images. I had exactly the same problem, and discovered it was with the burned DVD (the iso was fine); I had to burn it 4 (!!!) times before it worked right. And, perhaps take note here, using the various burned copies I found errors at different points in the install, as if there were random bad tracks (which makes sense with a defective burn). So . . . you may have two distinctly different issues (the formatting and the image installation), or just maybe, they’re related - a bad DVD (because the ext3 formatting would pull code from a different track on the DVD than the xfs format would - and perhaps a reason to try a live-CD like Knoppix or even PartitionMagic if you have it). Just a thought.

Thank you for all your help so far. Greatly appreciated.
OK so i tried a few things. I managed to get a hold of opensuse LiveCD booted from there. I also changed the size of the RAID. I created 3 RAID arrays, and i used the smalled one for linux which was 50 GB . Tried installing, and same thing. While copying root filesystem stops. So i change the filesystem type from ext3 to jfs, and then from jfs to xfs, then from xfs to reiser, and then it went through the copying part, but when it got to where it writes the boot sector to the disk, it froze again. So i just connected a new SATA2 drive to the computer, i installed linux onto that. Then i booted into linux, formated the 50GB Raid array as XFS, since its the fastest in my experience, so anyhow, i mounted it and then i copied a 600 MB folder from a cd to my home folder, and from there i was trying to copy it to the XFS formated 50 GB RAID array. It was all good it transfered in a blink of an eye, but as soon as the transfer was done, everything froze completely. Now since i have to do a restart, and can’t see the error that occurred, is there anywhere where that error gets logged somehow? or is there a tool that i could use in command line to see what error it gives me? I used cp -R but nothing.
Any ideas would be great. Thank you.


So i decided to go all the way back. Went into the bios, and changed the Raid 0 Array to Raid 1 mirroring. Then booted into linux, and it was recognized as /dev/sdc so - primary partition - /dev/sdc1 formated as XFS. Mounted it as /media/HDD.
Now i went to copy the same 600 mb folder onto it. Worked just fine. Nothing froze, and i was able to access the files off of it - but after a few minutes the drive just went away. I could still see /media/HDD and the folder in it, but it gave me no response. I tried to delete but nothing. So this time the system did not freeze, only the drive gave me no response. So i went back to the partition tool to see if i can format it again, but to my surprise the drive was not present anymore. So all i had was /dev/sda, and /dev/sdb , and /dev/sdc was gone almost like it would a removable drive, and i shut it off, only it isn’t a removable drive.
Question: 1. Is it possible for the PCI-E RocketRaid3120 controller to just power off the 2 drives connected to it?
2. What should i test/try to see what exactly is happening to the drives?