opensuse installation does not add ubuntu entry in grub automaticaly

after installing opensuse 12.1, opensuse does not recognize the ubuntu os which is installed on the other drive and there is no menu entry in grub
how do i add ubuntu in grub
my disk partitions are as follows

dev/sda1=swap
dev/sda2=root(opensuse)
dev/sda3=home(opensuse)
dev/sda4=extended
dev/sda5=home(ubuntu)
dev/sda6=root(ubuntu)

Please also post result of

su -
fdisk -l

But typically it’s like this

###Don't change this comment - YaST2 identifier: Original name: Ubuntu###
title Ubuntu
    root (hd0,5)
    kernel /vmlinuz root=/dev/sda6 ro quiet splash
    initrd /initrd.img

On 2012-04-09 11:36, caf4926 wrote:

> But typically it’s like this
>
>
> Code:
> --------------------
> ###Don’t change this comment - YaST2 identifier: Original name: Ubuntu###
> title Ubuntu
> root (hd0,5)
> kernel /vmlinuz root=/dev/sda6 ro quiet splash
> initrd /initrd.img
> --------------------

Why not firing up ubuntu’s grub?


title Ubuntu
rootnoverify (hd0,5)
chainloader +1

That’s assuming ubuntu’s grub is there, because probably it was in the MBR
and was destroyed :-?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Another alternative is:
Use Supergrubdisk to boot Ubuntu

Then run this in Ubuntu

sudo update-grub
sudo grub-install /dev/sda

Will let Ubuntu manage booting

On 2012-04-09 11:56, caf4926 wrote:
>
> Another alternative is:
> Use Supergrubdisk to boot Ubuntu

I have a bad taste with that. I needed it about two weeks ago, downloaded
it, booted, and got a nasty April fools joke instead. I could not recover
boot, I had to full reinstall - actually, dvd upgrade.

Do you know of a good download link for that supergrub thing?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002e591

Device Boot Start End Blocks Id System
/dev/sda1 2048 4208639 2103296 82 Linux swap / Solaris
/dev/sda2 * 4208640 46153727 20972544 83 Linux
/dev/sda3 46153728 780367610 367106941+ 83 Linux
/dev/sda4 780371966 976771071 98199553 5 Extended
/dev/sda5 849901568 976771071 63434752 83 Linux
/dev/sda6 780371968 849891327 34759680 83 Linux

Partition table entries are not in disk order

That’s messy.

Hopefully this is a OK Link Super Grub Disk | Free System Administration software downloads at SourceForge.net

If you go for using SUSE grub, you may just have to experiment

Use updategrub to add kernel and chainload entries and grubmenu to enable/disable them.
http://forums.opensuse.org/english/get-technical-help-here/how-faq-forums/advanced-how-faq-read-only/458238-updategrub-opensuse-legacy-grub-not-update-grub.html#post2329167

If it fails to add Ubuntu, mount the Ubuntu partition first. Then it will see Ubuntu’s kernel and add it. It’s a bug in os-prober (which doesn’t only affect updategrub under openSUSE but Grub2 under Ubuntu as well, since they both use os-prober).