openSUSE install problems

Hi,

I’m having some serious issues installing opensuse 11. I decided to swap over from kubuntu because I heard that suse has a better/more stable kde environment.

I tried using the kde cd image first and then the full suse 11 dvd image (with both I checked the media after burning.) Both freeze at some point during installation. From the kde disc it is when the kernel is loading and from the DVD it is when the completed install is being ‘inspected.’

I suspect the problem is related to the HAL deamon. It doesnt seem to be installed properly. So I guess a peice of hardware causing problems but Kubuntu has been running fine over the last few months.

I have tried failsafe and text based install. Also, after a couple of freezes during one install, I told the installer to not bother continuing installation (during ‘inspection’). This did provide me with an installation I could boot up in but it was only half finshed (user info was gone , it couldnt find any commands, and it died when i tried to lok at the hardware setup.) Using the repair installtion tool on the DVD from this point doesnt work either. I dont know enough about linux to know how complete this install is.

My hardware is pretty basic, along the lines of:
P4, 1GB RAM, ATi rad X1550,
Belkin wireless card (worked with ndiswrapper)

of course, I can give full details if someone thinks it is useful.

I also tried the new version of Mandriva and that also died during install. Again I believe related to the HAL deamon. Kubuntu/Ubuntu will still install and i run WinXP off the same box. So the hardware does work.

Does anybody have any suggestions? There doesnt seem to be any more options to try up to the point where things go wrong. I dont understand how an ‘unknown’ peice of hardware can fudge the entire installation? Would it have to be something critical?
TIA

  • uconin,

can you give us some more information on your hardware, especially the mainboard? Also, can you find out
at what stage the install stops?

Uwe

hi Uwe,

Here is my hardware in detail:

CPU : Pentium 4 , 3GHz
MoBo : MSI 685PE Neo2 (MS-6728)
RAM :1024 MB (2 x 512 DDR-SDRAM )
VCard : SAPPHIRE Radeon X1550 Series (AGP)

PCI:
Belkin Wireless G Desktop Adapter
Creative SB0090 Audigy Card

I thought that it might be my graphics card that is causing the problems. I think this is the case for the KDE CD install of suse because I can’t select VESA graphics mode at the install. I know that on Kubuntu, if i tried to use the fglrx driver it wouldnt work at all.

Anyway, using the full suse DVD, setup goes through the initial install process, up to the reboot, without a problem. After rebooting, setup continues with the system configuration process. This is where it freezes. If I select manual configuration it freezes immediately, during the check installation stage. Basically it freezes as soon as the setup gui appears on the screen.

If I use automatic configuration if freezes during the initialisation.

In both cases, after reboot, I am told that installation has failed and asked if I would like to continue. If I say yes, the setup gui opens and it freezes - same as before. If I say no, then boot up continues and I am left at the login screen.

If I used manual configuration, then my user info I entered is not saved but I can log in as root. If I used automatic configuration then the user details are saved and I can log in normally.

Once logged in everything looks fine but when I open the Network Configuration tool from Yast the PC freezes again.

However, because the installation didnt complete I have no idea how complete or stable the install is.

Using the repair installation service off the DVD from this point tells me that hal,cups,ntp and postfix are not installed correctly.The repair system finishes ok but then when I click exit Im dropped into ‘expert’ mode and informed that an error occurred during installation.

So maybe the network card is the problem.
I’m going to try a bios upgrade and an install without my network card installed - when I get some time.

On 11/27/2008 uconin wrote:
> I’m going to try a bios upgrade and an install without my network
> card installed - when I get some time.

That’s exactly what I’d try, unplug the NIC for installation. Let us know if it helps.

Uwe

Hi,

install went perfectly, the network card was the issue. It seems pretty obvious in retrospect. Whatever suse is using by default to run the card is clearly no good. I am suprised that an issue like this would botch an entire install. Well, I guess what I mean is, I am suprised that potentially buggy drivers are installed by default.

Anyway, thanks for the interest Uwe. Is it worth reporting this as a specific problem, do you think?

  • uconin,

if it works now, i.e. if you simply plugged the NIC back in after the install and it worked, yes. Please check bugzilla.novell first, maybe it is a known issue.

Uwe

Hello All

I was recently given an Emachine 220 with a copy of windows xp home on it but gave the license to a family member. Not wanting to throw away a perfectly good machine I decided to give Linux ago.

I’m new to the world of Linux so I’m not sure of the terms you use, eg HAL deamon, I have no idea what it is. But I’m having the same problem with the installation.

I have tried different settings, tried the repair wizard and the same files *‘hal,cups,ntp and postfix’ (plus another one, sorry can’t remember) *, come back ‘changed from the original installation’.

Once again the problem only happens after it reboots and is auto configuring (part way though) or when you try and do it manually (at the start).

Any ideas of a fix?

Any help would be great.

Thanks

Matthew

I am currently running XP pro, and want to run OpenSuse 11.1 with KDE 4 as well. I used to have Kubuntu 8.04 running alongside XP on my old PC, using the slave drive, and am wondering if I should partition my slave drive and install OpenSuse 11.1 on it. What do you think would be the best way to do it?

Cheers

John

Folks,

please start new threads (after reading the forums to find possible solutions possibly solving your problems, especially the stickies). This is more efficient than adding your problems to a (probably) unrelated thread.

Uwe