opensuse install problems AMD

OK so i used to own a laptop i paid like 1200 u.s. dollars for right. It came with some kind of Intel core i7 CPU i think 2200h and a nvidia gtx 1060 So i tried to install opensuse leap and tumbleweed on it and it would just freeze or hangs on the boot or splash screen. Eventually i gave up and got rid of the laptop. That was last year NOW i have just invested in an all AMD laptop with a ryzen 5 3550h cpu in it and a rx560 graphics card well i have tried to boot it from USB with nomodeset and nomodeset=0 on both the normal x86_64 iso and the LIVE version but still it will refuse to boot why is this and how can i fix the problem i REALLY want to use opensuse i love it and it works fine on me and my wife’s old laptops no problems and no its not the install media and I have tried turning on/off tons of bios options like secure boot on or off or USB legacy and UEFI to no avail. The new asus all AMD laptop seems to boot into any windows and Linux operating systems just fine just like my last gameing laptop except opensuse please help me thank you very much.

Mine won’t boot any Linux ISO’s (Ryzen 2700U/Vega10) unless the bootline is tweaked with iommu=soft. Forget nomodset with Ryzen.

From the grub.cfg file:

menuentry 'Installation' --class opensuse --class gnu-linux --class gnu --class os {
  set gfxpayload=keep
  echo 'Loading kernel ...'
  linuxefi /boot/x86_64/loader/linux splash=silent iommu=soft
  echo 'Loading initial ramdisk ...'
  initrdefi /boot/x86_64/loader/initrd

yea i tried that and it makes no difference i cant boot any linux OS at all btw so like wow this is annoying

If you can’t boot changing the cfg is tricky LOL

At the boot screen press e find line starting linux or linuxefi. go to then end (note it may rap) add space and iommu=soft

Note this is a one boot change to change permanently follow above instruction

Also note some BIOS/UEFI allow change in iommu settings so may not need to modify grub

yea i tried that option already it dident work so now what its like this with manjaro as well no matter what i do.

Or, from Windows, insert the TW flash drive and search for this folder in File Explorer:
EFI>BOOT>grub.cfg>Open the file with WordPad> add a space at the end of the linuxefi line and type iommu=soft. Save, wait and exit.

This is a permanent fix, no need to edit Grub after. This tweak migrates in Grub after the installation and the installer is set to go. There are others bootline arguments to deal with,let us know if iommu is not working.

As seen from TW (Kate):

 menuentry 'Installation' --class opensuse --class gnu-linux --classgnu --class os {
  echo 'Loadingkernel ...'
  linuxefi/boot/x86_64/loader/linux splash=silent iommu=soft
  echo 'Loadinginitial ramdisk ...'

All the best,


GRUB_CMDLINE_LINUX_DEFAULT=“splash=silent iommu=soft resume=/dev/disk/by-id/ata-SanDisk_SDSSDH3256G_183756420226-part4 quiet mitigations=auto”

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.2.0-rc6-2.gf99f70b-default root=UUID=c2baf00f-f14a-4218-a75b-f056faa86a47 splash=silent iommu=soft resume=/dev/disk/by-id/ata-SanDisk_SDSSDH3256G_183756420226-part4 quiet mitigations=auto

Please provide some details on your meaning of “refuse to boot”. What’s the last thing that appears onscreen when you try? What’s the last key you struck before apparent response stopped? What else are you not telling us? TW20190623 installation starts normally with my older AMD GPU, and a much newer Intel GPU.

BTW, nomodeset is a troubleshooting parameter, something to try only if there is a purely video obstacle to either booting, or getting X running.

Have you tried a legacy install. Not uefi.

On a Ryzen 5 PC, the card ssd was not being recognized although root had been installed on it.

no nothing changed when i edited grub. sorry let me explain more so i boot the usb flash drive then get to grub then with Tumbleweed i boot for install the green bar onscreen loads and i press the escape key and all it says is

loading basic drivers

its all i see. When i load tumbleweed live the last things i get are

dracut initqueue hook...
 [8.447954] dracut-initqueue[617]: mount: /run/overlayfs: cant find LABEL="cow" 
 [8.600191] dracut-initqueue[617]: mke2fs 1.45.2 (27-may-2019)

then nothing on the tumbleweed live

with manjaro i get

 OK ] started load/save RF kill switch status.
 -*- ] a start job is running for monitoring of LVM2 mirrors, snap*s etc. using dmeventd or progress polling (32s / no limit)

then nothing it stops or freezes live everything else can press the escape key again.

in linux mint i saw something for a second before getting a black screen

error AMDGPU number of connectors=0

p.s idk if it matters but my laptop is a asus tuf fx505dy

NOTE: fedora complains something about ACPI on display 0 and 1 and puppy linux wont boot also.

ok so i finally got opensuse to boot and install idk why all the other linux operating systems seemed to point towards a gpu problem but apparently its the NVME drive they put in my laptop a western digital black has problems so adding to the line of linux in grub you hve to add this for anyone else with problems also wifi dose not work until you fix it later in OS.

GRUB_CMDLINE_LINUX_DEFAULT="quiet nvme_core.default_ps_max_latency_us=5500"

Happy ending!

We also have no WIFI after the fresh install, but we find a quick fix during the installation.

Bug Location In TheTumbleweed Installer for Ryzen 2700U


Network Configuration:

-Switch to wicked

-Switch back to network manager

This double switching action triggers WIFI circuitry on first boot. It enables its full functionality…

my wifi dose not work that did not fix the issue i tried to install the driver but failed i have the rtl8821ce and i have tried everything to get it to work is there an easy way to get this card to work thanks.

You mean you did a second fresh install and try the easy fix above? You may try the latest stable Kernel, choose the third one (debug):

[x]kernel-debug-debugsource-5.1.15-7.1.ge222743.x86_64.rpm (65M)

Open with Install/Remove Software = Yast will open. I try them all and always have the latest in backup, but I’m using mainline Kernel which is for Ryzen the best place to be.

What is your reading there?

sudorfkill list

Force WIFI network in Yast>system>services manager>networkmanager>start>on boot>+>systemd-networkd>>start>manually.Apply changes. Do you see the WIFI icon?

rpm-qa | grep -i  kernel 

Did you get this today with ucode-amd? Yast>SoftwareManagement>Extras>Show History

rpm-qa | grep -i  kernel-firmware

TW is way behind schedule with stable Kernel, they even downgrade it with the last ISO 20190624. This is not a good news because Kernel 5.2 will reach the stable channel in 2 weeks.

You should take a look at the manufacturer website to see other options for Linux. Our laptop has a 24 page thread (Firmware bug ACPI IVRS table).

See this thread, but we never downgrade and we are not using such driver. Mainline Kernel is our only fuel. Same apply for Google Chrome Unstable, it is their stable release.

Other Method to force WIFI

1.Yast>System>Network Settings>Global Options>Network Setup Method>Wicked Service>OK>This is the bug we have after a fresh install. No WiFI at all.

2.Yast>System>NetworkSettings>Global Options>Network Setup Method>NetworkManager Service>OK> Bug Fix, same as the installer.

i do that and after step 2 it just says error no network running???

also i started a thread more suitable here

ok whatever i just had a friend who was willing to trade me wifi cards in our laptops because he uses windows so problem solved

Had same issue, set kernel parameters before booting USB image. edit the kernel line, add “nvme_core.default_ps_max_latency_us=5500”