openSuSE having a hard time refreshing 22" screen

Hi everyone.

I run an openSuSE 11.0 (GNOME) on an Acer Aspire E360:

AMD Athlon 64 X2 3800+ / 2 GHz
NVIDIA nForce4 / 1000Mhz bus
250 GB - Standard - Serial ATA
NVIDIA GeForce 6100

and finally, an Acer AL2216W 22" Flat Screen LCD Monitor on 1680x1050 resolution.

Here is my problem: Everytime I move something in the screen too quickly (like the scrollbar) or if I activate the screensaver, I see “phantom” images in the corners and it seems to me that the refreshing rate is not keeping up with the system.

I recorded two cheap videos to try to show this issue:](

Remember, though, that these phantom images appear only for a fraction of a second, but they appear repeatedly and constantly specially when using applications in fullscreen.

Is there anybody else with a 22" screen having the same problem?

PS: It happens also in the LiveCD version

For those who do not want to watch the videos, I also uploaded a picture showing the issue while the “molecule screensaver” was activated.

What version of the video driver are you using?


I believe I had the latest one and I just updated the drivers from NVidia and still no improvement.

I also tried to change the configs and still nothing changed.
One of the configs that I tried was to activate NoAccel and that slowed down the system tremendously.

Also, another information to be added into this investigation:
The maximum amount of colors that I’m allowed to pick is 16.7 million [24 bit] whereas in windows XP I was getting 32 million.

Interestingly enough, whether related to this graphic issue or not, Google Earth crashes on my openSuSE 11.