OpenSUSE Has Drives Confused

I installed OpenSUSE 11.1 KDE on my desktop computer this evening. The problem is, it seems to have my hard drives confused. My slave drive, which should be /dev/sdb (hd1), is being recognized by SUSE as /dev/sda (hd0) and my master drive, which should be /dev/sda (hd0), is being recognized as /dev/sdb (hd1).

I had to edit my menu.lst file in order to get anything to boot at all. I got that working; but the problem is that every time I boot, Grub is unable to be located (most likely because it’s on hd1 and the boot record is looking for it on hd0).

What do I need to edit in order to fix this? Thanks.

Un-confuse yourself.
Are these sda, sdb
or hda, hdb?

With sda, sdb there are no slave / master
But are set by order of connection to sata sockets on the mobo and HD boot order in BIOS

While it’s entirely possible and very likely that I am confused, I believe you misread my post.

They are sda and sdb. Grub refers to them as hd0 and hd1 (first and second hard drives).

Grub is looking on hd0 for the /boot/message, but it’s not finding it, because that file is on hd1. Therefore, after an error pops up, I’m kicked to a plain text version of the boot menu.

I hope that helps clear things up.

BTW - I think I figured it out, but I am getting ready to restart to find out. It appears that the “/boot/message” location is stored at the top of the menu.lst file, which I’ve edited, now. I’ll let you know. Thank you.

I have solved the problem and gotten Grub to work properly.

Just to clear things up, here is my hard drive configuration:
I have a SATA drive on which Windows is installed. That is generally recognized as my first drive. Grub recognizes that as hd0. That is where my Windows boot record is stored.
I have an IDE drive on which Mint and OpenSUSE are installed. That is generally recognized as my second drive. Grub recognizes that as hd1. That is where my Grub boot records are stored.

For some reason, SUSE seems convinced that my IDE drive is hd0 and keeps auto-configuring things to look there for my Linux stuff. Unfortunately, my IDE drive is actually hd1, according to Grub, so it never finds what it’s looking for until I’ve replaced all of the instances of “hd0” with “hd1” in /boot/grub/menu.lst and vice versa.

For now, my problem is solved. However, I noticed that kernel updates add new items to my menu.lst, which are then incorrect again.

At least you have it sorted so I’ll refrain from explaining any further about sda and hda / ide and sata