OpenSUSE hang on power unplug

Hello guys

My laptop hung when external power is unplug. I guess something went wrong with my wireless device, so i investigate system log for information. But unfortunately, it didnt tell anything about the case. What next do i need to do now? Im new to OpenSUSE.

My laptop is a brand new Dell Vostro 1014

Thanks in advanced.

Check your settings in the power manager
What is it set to do when switch to battery

It might be an idea to tell is if you are using kde or gnome
You could for example have on battery with the same settings as when plugged in, which may prevent this issue happening

Thanks caf4926 for reply to my post.

About the power management setting for battery. Originally it is set to: powersave. But, even if i switch it to Performance (same mode as when on power plugged), it doesn’t helps at all. By the way, i used KDE as primary desktop manager. Any ideas?

What setting do you have under

‘When AC is unplugged’

Under When AC unplug there are 3 choices:

  1. aggressive powersave
  2. performance
  3. powersave

no matter what option was chosen, it always produce the same result.

problem solved.

after a whole day long trying to figure out what was wrong, i found that the problem happens with pm-utils package (pm-utils-1.4.1-5.1). So, after update this package with the newest package (pm-utils-1.4.1-19.1) from openSUSE repositories, the problem has gone.

btw, thanks caf for trying to help.

That’s interesting
Thank you so much for letting us know

Just to be sure.
Can you confirm what version of openSUSE you have

I am on 11.4 and my package is: pm-utils-1.4.1-5.9.1.x86_64
I’m OK though

sure, im on 11.4 and my original package is: pm-utils-1.4.1-5.9.1.i586 and im not OK, lol.

Just out of interest
Where did you get the updated package?

I get it here:

Thanks for that