Opensuse guest in VMWare; can't get full screen

Hi all. I have been trying to find the solution to the problem for days now. I have a Windows 7 host with OpenSuse running in VMWare. When I first installed OpenSuse, I was able to press the full screen button on VMWare, and the resolution of OpenSuse would automatically resize to my monitor resolution. However, after the first restart (with no updates), this feature is no longer working. I have now installed all the recommended updates with no changes. I am using the open-vm-tools packages that come pre-installed, not the official VM package.

Perhaps “Autofit Guest” settings have been changed in the configuration? ( Edit > Preferences > Display )

Especially for the full screen.

I am using VMWare player 12, so I don’t have those options exactly. However, I checked every setting available for video, and everything looks right. I have also turned on and off graphics acceleration, and tried to manually specify my monitor resolution. Neither did any good. I’m not sure if there are any settings in Linux that need to be checked; I’m more of a newbie for Linux.

I use VirtualBox rather than VMWare so don’t have experience with the latter, however from a quick search online I wonder if you perhaps need to install ‘open-vm-tools-desktop’ to get this functionality operational?

To have Guest full screen capability

  1. You need to have the Guest Tools installed, or at least the community version. Typically, this should be done automatically if you install openSUSE from source (eg DVD or net) and not simply copied over from another HostOS in which you won’t know how the Guest was created. For VBox, there is a package as deano points out. For VMware, Tools is now part of the 4.x (and later) Linux kernel so nothing needs to be installed although some functions like Shared Folders and Hardware Passthrough may require configuration (see the SDB below). If you are installing an older openSUSE (kernel 3.x or earlier), then you still need to build VMware Tools (There is a link to the rasa project in the SDB below that builds quickly with scripts. Or, search these Forums for my previous posts or ask again).
    https://en.opensuse.org/SDB:VMware_Tools

  2. You need to install a Desktop that supports an advanced GPU driver. If you’re installing a Text-mode Server or a simple Windows Manager like MinimalX (I think that’s OpenBox, but this needs verification), then you won’t have an automatic full screen capability but you can configure almost any resolution using xrandr (or a graphical front end like arandr).

HTH,
TSU

Thanks for the replies. After playing around with it a little more, I just gave up and switched to VirtualBox. All good now :slight_smile:

Never give up Zach, you can do it! :wink:

tsu2’s reply should get you want you need in VMware - not sure if you paid for Workstation or not, but I’d hate for you to waste that money if you don’t have to.

After some long thought,
I suspect that the OP didn’t know how to go to full screen (or undo full screen back to the graphical console), which the key combination

CTL-ALT-Return

TSU

I had the same problem w/ vmware workstation12.5.4 & Opensuse Leap 42.2, I resolved the issue by changing the display on the vm (VM > Settings > [Hardware Tab] click on Display) from auto to matching the resolution on my monitor (1920 x 1080).

Another scenario occurred to me…

VMware Tools is installed automatically in openSUSE only if you install openSUSE in the virtual environment.

I can think of two scenarios where this wouldn’t happen automatically…

  • Your Guest is a P2V.
  • Your Guest was originally created in a different virtualization technology, then re-deployed which means the wrong Guest Tools/Additions are installed.

Bottom line is that if you have the proper Guest Tools/Additions installed and not running a generic video driver (eg VGA, SVGA, XGA, etc) in the Guest, then your screen should support automatic re-sizing. In openSUSE, this typically means that your screen won’t re-size automatically if your Guest is a Text-mode server, or running an OpenBox environment like when you’re running MinimalX/IceWM. If you’re running practically any true Desktop, then you should satisfy the video requirements.

TSU

------- Just FYI , Upgraded to 42.3 today and it works for me. The same problem had occurred on 42.2 on Vmware Workstation 12x
It works fine on Virtualbox as you said.

In one of my 42.2 systems, I was able to create a curious problem…
Although there was no problem going full screen, it appears that the background image won’t stretch, tile or re-position to fill the screen.

So, am wondering if the OP (and any others who may claim to be experiencing same) are actually describing a background image that won’t “go full screen” and not the Desktop itself.

Trying to duplicate the problem in 42.3, this seems to be fixed. There is no problem for the background image to fill the full screen by any of the configurable methods.

Am seeing this on LXQt Desktops overlaying LXDE.

TSU