OpenSuse gobbled the whole 600gb drive

1st let me admit anything that is wrong is probably
my fault as I am green with OpenSuse.
Dual booting Vista and OpenSuse 11.2
Hd 1 Vista (80GB)
Hd 2 OpenSuse 11.2 (600GB)
I don’t want to delete OPenSuse and start over again
because I had a terrible time with Grub and Dual booting.
“Easybcd” did not help much.
What I want to do is resize the OpenSuse sdb3 partition
to 200gb for OpenSuse and 350gb not used.
I have no idea how big the sdb3 file is.
I tried Partition magic and Gparted. Neither would resize
the OpenSuse sdb3 file.

You will need to post the output from;

sudo /sbin/fdisk -l

That’s a minus sigh and a lower case L at the end.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 1:15, 2 users, load average: 0.14, 0.09, 0.09
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

Thank you for answering Malcolmlewis.
Hope this is correct as I don’t know how to copy what the
sudo command listed so I had to hand do it.

Device Boot Boot Start End Blocks Id System
/dev/sdb1 1 262 2104483+ 82 Linux swap/Solaris
/dev/sdb2 * 263 2873 20972857+ 83 Linux
/dev/sdb3 2874 77825 602051940 83 Linux

Ok what about fstab;

cat /etc/fstab

Just to confirm what is being used for /dev/sdb3 I’m assuming
it’s /home?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 2:38, 2 users, load average: 0.14, 0.14, 0.10
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

cat /etc/fstab per your request
Also just tried Parted Magic and it won’t resize the sdb3 partition either.

/dev/disk/by-id/ata-wdc_wd6400aaks-00a7b0_wd-wmasy3678284-part1 swap swap defaults 0 0
/dev/disk/by-id/ata-wdc_wd6400aaks-00a7b0_wd-wmasy3678284-part2 ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-wdc_wd6400aaks-00a7b0_wd-wmasy3678284-part3 ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-st380815as_6rw1tz61-part1 .windos/c ntfs-3g
users, gid=users,fmask=133,dmask=022,locale=en_us.utf-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

What version is your parted? You probably need a recent one with ext4 support.

Parted Magic 3.5 Has EXT4 Support - Easily partition your hard drives with Parted Magic. - Softpedia

Thanks for answering ken_yap.
I just downloaded Parted Magic v. 4.8.iso.

Maybe I just missed something as it’s the 1st
time I have used it.

You missed the mount points for the above. I’m guessing part-2 is / and
part-3 is /home please confirm.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 4:15, 3 users, load average: 0.20, 0.13, 0.12
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

So sorry, my fumbling fingers.

/dev/disk/by-id/ata-wdc_wd6400aaks-00a7b0_ wd-wmasy3678284-
part2/ ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-wdc_wd6400aaks-00a7b0_ wd-wmasy3678284-
part3 /home ext4 acl,user_xattr 1 2

Don’t know how to mark this thread as solved.
Just a matter of using the right part of Parted Magic.
Thanks for everyones help.

Ok it is /home, so here goes :slight_smile: You need to log out from the GUI and
then press ctrl+alt+F1 this will give you a console terminal. You need
to login as your root user.

init 3
umount /dev/sdb3
yast disk

(You may need to use the ctrl+alt+F1 to get back) This will unmount the
home directory and the second command starts the ncursers version of
YaST, you need to use the tab keys to get around, but you need to;

  • {tab} to the System view’, then
  • arrow down to ‘Hard Disks’ and press the {spacebar} to expand,
  • arrow down to sdb and press {enter}

This should put you over into the Partitions

  • press {tab} to get to the list of sdb1, sdb2 and sdb3
  • press arrow down to /dev/sdb3 and then
  • {tab} three times to get to resize and press enter
  • use the arrow keys and spacebar to select Custome Size,
  • {tab} in the size and enter 200 GB
  • {tab} through to ok and {tab} through to finish

This should resize sdb3 for you, next you need to remount and check;

mount -a
df -k
fdisk -l

If all ok, then run;

init 5 && exit

You might want to print this out before you start :wink: or copy and paste
to a text file that you can cat out.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 0:08, 3 users, load average: 0.56, 0.59, 0.31
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME