openSUSE for Intel Chromebooks

Does anyone know of any current attempts to develop an openSUSE version for Intel based Chromebooks?

I have looked at the offering on but did not attempt an installation as it involves hardware modification (voiding the warranty) and flashing ROM. In addition the user who started the project has terminated the work. I am currently running KDE under Ubuntu 12.04. I’m not a fan of Ubuntu.

Chromebooks appear to be selling very well, and I must admit that for people who only want to surf the net and use E-mail it’s hard to beat a $200 Chromebook running its native OS. Of course some people want more.

I may be wrong, but seems to me that replacing ChromeOS with another OS will probably void your warranty, anyway. So, why not go all the way and follow the instructions in your link. Like I said, I may be wrong about this.

I have not replaced the original Chrome OS. Ubuntu runs alongside Chrome OS. I would expect openSUSE to do likewise.

I understand.

I’ve ran it on 2 Acer C720’s. I did not run a custom bios, I just set the bios to use the legacy seabios. I also did the remove the write protect then put it back after the writting to it.

After that I just loaded 13.1, 13.2, several other OS’s, and this very minute just booted up TW from a USB stick.

TW has the 3.18 kernel that has Chromebook support for the keypad. There still seems to be a lack of suspend / wake baked into it. Might be some systemd stuff you can mess with in the terminal.

No need for keyboard for 13.2, but you will need a mouse.
No need for either if putting TW on.

I just finished creating a bootable USB stick with your suggested Tumbleweed (openSUSE-Tumbleweed-DVD-x86_64-Snapshot20150225-Media.iso) on it and installed it on my Acer C-720. The installation was incredibly fast and booted successfully, but I have no mouse or touchpad cursor. I did read that there were patches available to correct this and will work on it.

Thanks for the suggestion.

After I updated the installation my cursors came back and I am currently installing software. Thank you VERY much for the advice. I can now connect it to my LAN which the Ubuntu/Crouton method could not do as it was booting the ChromeOS kernel which does not support NFS. Possibly to promote their cloud services. I think this is important news for new Chromebook owners and I think you should broadcast this solution as loudly as possible.

I have been kind of talking about it, but I still have a suspend resume problem I can not quite figure out with my Acer.

1: It will not suspend when I close my lid unless the power cable is plugged in.
2: When it is plugged in and does go to suspend when plugged in I can not get it to resume or wake up.

I’ve tried a lot of different things that I’ve come across, but end up with the same result. I don’t know if it is a gnome, systemd, bios, or sensor issue. I think I’m going to have to look in just regular posts about suspend/resume to solve this instead of chromebook specific posts about it.

When I figure it out I will post up clearly on how it works great on my little i3 Chromebook and how to fix that little quirk.


Well I did figure it out. Do get it to work correctly you NEED to do the John Lewis flash. All I did was remove the #7 write protect screw for my C720 like last time and ran the script. After that was done, I powered down, put the screw back in, and booted up.

On bootup the date was way way off. I wiped everything and started from a fresh install of Tumbleweed.

I followed every step of this unreviewed How To starting with the install from a USB live or Install stick.

Notice that I skipped Step 26 since I use gnome, so keybinding didn’t work. Not a problem for me I can map them myself anyway.

Notice that Step 28 has a typo correction a post or two bellow it. C/P the code from the follow up post about it. The original post was not modified yet.


I made the edit a few minutes ago. Hopefully my copy and paste is correct and I did not screw this up.


Tumbleweed is still running awesome with no issues yet.