OpenSuse Different Library Names

Hi all.
I have downloaded stardict 3.0.4 .tar from
when i try to run ./configure it gives me the message that

configure: error: Package requirements (gtk±2.0 glib-2.0 >= 2.8 zlib libxml-2.0 >= 2.5) were not met:
No package ‘gtk±2.0’ found
No package ‘glib-2.0’ found
No package ‘zlib’ found
No package ‘libxml-2.0’ found"

but I have installed all of them,zlib,libxml2-2 gtk2 and gtk3 and glib,and all the versions are higher than the required.

what’s wrong?
I have seen later that some names of opensuse libraries are different than other distros, i mean they have some letters of semiword inaddition to the orginal name.
How to fix that?

To compile, you need the -devel versions of the mentioned packages to be installed.

But… did you check this:

Yes.It’s version 3.0.3 in repository that has a little bug annoying me.

but so very thanks for your help.
Solved :smiley:

On 01/09/2013 09:46 PM, phenomx64 wrote:
> I have downloaded stardict 3.0.4 .tar from

instead of tripping around the net and picking up apps from who knows
who (ok, so we know Google, but), why not just use the neat, tidy and
hopefully CLEAN and easy to install applications in the openSUSE repos??

stardic is right there in the basic oss repo, so just pop open YaST >
Software Management, search on ‘stardict’, mark it for installation and
then click “Accept”…done, no messing around with downloading,
compiling (after finding all the pieces, some with different names
depending on the disto, etc etc etc), installing, figuring out how to
add it to a menu, etc etc etc…

OR, just pop open a terminal, become root with “su -”, and enter

zypper in stardict

done! don’t even have to open YaST

OR, go to, click the tool icon and dial in
your openSUSE version number, type in stardict and follow your nose…

but, to your question “what’s wrong? . . .all the versions are higher
than the required.”

well, “higher than” is not always “better than” or “good enough
for”…that is, if i tell you stardict requires libsomething1.2.3 you
should not assume it will run with libsomething1.2.4, 1.2.5 or anything
other than what it requires (in this case lib1.2.3! if you don’t give
it 1.2.3 it very often won’t run.)

and, when you say “but I have installed all of them”, so how did you
install them? did you use YaST or zypper so that everything gets to the
correct place, and all the links are set up as required, or did you just
… . . . what? (they must be installed correctly, and if you manually
installed them all to the correct places, did you then run ldconfig to
get them rescanned by the system??)