OpenSuSE CD fails to load on a no-frills PIII computer

Hi there.
After falling thoroughly in love with OpenSuSE 11.0 (been using it on my production laptop 24/7), I just couldn’t resist installing it onto our family desktop as well. Alas, the live CD never loads past the step “configuring Xserver”. After that, it just drops me to the console prompt. I’ve tried VESA boot, 800x600 boot, safe mode boot - no go. It just doesn’t get to the graphical desktop. And considering that this is just an old plain vanilla Pentium III computer with no frills whatsoever! An Abit VH6T mobo with PIII/800EB, a Maxtor 80GB IDE drive, and an Asus Nvidia GeForce 7100 AGP graphics card - that’s as classic as it gets, in my opinion. The strange thing is, no other distro will boot on this essential setup - with the exception of Mandriva (and, well, ehm, “that other OS”). With “boot” I mean to say “get to the graphical desktop”. Not Ubuntu, not Kubuntu, not Xubuntu, not Fedora, not Knoppix, not PCLinuxOS, not Freespire. Isn’t it a bit strange that this should occur on such a simple, proven, down-to-earth configuration? Does anybody have any suggestion or first-hand experience as to where should i look for the culprit? I currently run Mandriva, but I’d really really love to have SuSE on both our machines.
And no, the computer is not faulty - in Mandriva (and in that “other OS”) it works like a charm - including ACPI, power saving, suspend-to-disk and other tricky features!
Any ideas?

There is also a text install. Did you try that?

I confess, I do not know if openSUSE is compatible with a PIII/800EB

A text install? How exactly do you do that? I can’t remember any such option in the live CD boot menu. And, most importantly: can a text install get you to a working desktop environment at the end, or is it only for command-line linux?
Sorry for being such a noob…:frowning:

I managed to install openSUSE 10.0 - 11.0 on an old PIII Dell Dimension XPSB733r. I originally had 128 MB of RAM.
However, the installation would lock up due to insuffcient physical RAM.

You must have a minimum of 256 MB of physical RAM.

Sorry, but that board is not “simple, proven, down-to-earth”. The Abit vh6t uses a VIA (the “v”) chipset, which besides being the, er, least expensive, has been and especially was so at that time, very flakey. That so many distros have a problem with this system makes it highly likely that the issue is the chipset.

On the Live-CD menu, in the Boot Options below, type this:

pci=nomsi

That works around one of the most common flaws in this chipset.

Thanx a bunch, I’ll try that. It seems I jump to conclusions too fast:shame: The mobo obviously is not that proven… As for RAM, there’s 320 MB installed, so I don’t think that is an issue. Thanx for your replies, guys!
Although, one should think that the linux developers could have found a solution for those VIA chipsets. After all, it’s been ages since this mobo came out…

Actually, the above is the solution in most cases. And it is used with VIA chipsets much newer than yours (at least VIA is consistent ;)). But the problem is, can’t be used every time, so needs to be an add-on kernel argument.

I’m not at home, so I can’t access my notes nor a sample openSUSE CD/DVD. But one of the function keys on the installation will provide you the option for a text install. Plus I think there is a key sequence one can hold during the installation CD/DVD boot that will also start a text install. I simply can’t give you the details now, with me being “on the road” so to speak.

And yes, a text install will install all the software needed for a GUI, as long as you select it. I recommend you do NOT select KDE4.

Thanx, guys. You were of real help. Take care and be well!

Update. Unfortunately, neither pci=nomsi nor text install seem to cut it. I’m left with a frozen console prompt and the keyboard is not responding.:frowning:
What the heck is Mandriva doing differently so that it manages not only to boot the live CD seamlessly, but even to install on the hard drive without a glitch!!!@#**!@!*

Why don’t you give the DVD a try? Better yet, the 11.1 Beta 3 (within a few days)?

With the Live-CD you have, after it borks trying to configured the X server, from the command line see if there is a /var/log/Xorg.0.log file that was written; may tell you why it choked.

As far as why Mandriva worked - that’s not really mysterious. Different kernel version, kernel patches, which modules built into kernel, kernel configuration options, graphics driver versions, X server version, etc. Your machine has a “quirk” which Mandriva’s particular software mix works around; others not. That happens.

Just to confirm, … did you :

  • check the md5sum of the downloaded iso file against the md5sum on the download web site?
  • burn at the slowest speed your CD burner allowed?
  • burn on to the highest quality (most compatible) CD media you have?
  • perform the media check prior to installation, to confirm your installation CD was good?

Hi, thx for your concern.
Maybe I wasn’t clear enough: the machine freezes completely while trying to configure the xserver. How am I supposed to check /var/log/Xorg.0.log when the only thing that works is the reset button on the case?
As for the CD media: yes, I did check the md5sum, and yes, I did perform a media check; moreover, the laptop I’m writing this post on was installed from the exact very same CD that now won’t install to my other box.
I really think I’ll wait for 11.1 final to come out and try again with that. Until then I’ll stick with Mandriva (it’s not heavily used anyway, mainly as shared storage on our home network and for occasional Internet browsing).

Use the DVD.

Does the installer work in less than 512MB ram at all? I thought that was the minimum. In fact, with 1GB on a P3 system there were no issues and on a similar system with 384MB there were multiple issues.

The other common issue is the install media. Some older cd drives are very particular in what will work. The media itself may be damaged. If you downloaded a development version there may be a flaw in the iso.

For now, do your normal boot and when you get to the text console type ‘sax2’. That may be able to configure the graphics system. You may need to restart xdm with ‘/etc/init.d/xdm restart’. If that doesn’t get a working xorg.conf file, type ‘startx’ and report the error.

I’ve installed 11.0 on a machine with 256MB RAM even. Yes, the GUI works, and a probe of memory use shows that the footprint is only 100-150MB. Those guys at KDE have done a great job in reducing the footprint so that even with more functionality, the memory requirements haven’t gone overboard.

For anyone interested: I intend to give it a try when 11.1 comes out, and then report back here. If there’s anything to report, taht is.:wink: