opensuse can't recongnize my mac partition

hey guys, I’m new to opensuse. I just installed opensuse11 on my macbookpro, everything is fine, but I don’t know why opensuse can’t recongnize my mac partition.
I run fidsk -l, and I got this
WARNING: GPT (GUID Partition Table) detected on ‘/dev/sda’! The util fdisk doesn’t support GPT. Use GNU Parted.

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x2d6f99e7

Device Boot Start End Blocks Id System
/dev/sda1 1 26 204819+ ee EFI GPT
/dev/sda2 26 17470 140122880 af Unknown
/dev/sda3 17470 17531 488281+ 82 Linux swap / Solaris
/dev/sda4 * 17531 19458 15474906 83 Linux

Please help, Thanks

Hi! Have you tried using GParted as the first line suggested? My guess would be that fdisk actually doesn’t support GUID partition tables (they’re fairly “new”), that’s why it’s suggesting you use GParted. Just to clear out: what do you mean exactly by “SuSE doesn’t recognize my Mac partition”? You mean you can’t browse your Mac partition with a file browser, or it doesn’t even appear as a mounted volume or what? I’ve never used a Mac so I might be talking nonsense here but: there is a very remote, though highly improbable possibility that a certain type of Mac partitions is not (yet) supported in linux?
Anyway, best of luck!

HFS support is not included by default when you install SUSE. You can add it via Yast or zypper.

There are two packages that support this: hfsutils and hfsplustuils

The difference is hfsplusutils is read only. hfsutils provides r/w capability.

I have never personally used these though, just am aware that these packages are needed to access Mac partitions.

Cheers