openSUSE cannot set monitor refresh rate to 1280x1024@75hz

I install openSUSE 11.1 and graphic drivers for ATI RADEON 9550 on monitor BELINEA 1705 S1 and everything work fine bat in display manager there is not 1280x1024 and 75hz option, on low resolution 75hz is there. I don’t know how to fix this. In manual for BELINE 1705 S1 wrote that is 1280x1024@75hz working resolution.

1280x1024:
http://i41.tinypic.com/al0o53.jpg

LOW RESOLUTIONS
http://i39.tinypic.com/2ia99cj.jpg

Try this command from shell prompt:

xrandr -q

It should output the modes compatible with your monitor. However, sometimes the EDID reporting does not work perfectly.

You can try changing display mode with something like

xrandr -s 1280x1024 -r 75

If still not working correctly, then you may need to edit /etc/xorg.conf manually, with the addition of a modeline for the required resolution and refresh rate.

It’s not working!
there is not mod 1280x1024@75hz.
Please tel me how to configure xorg.conf,
or how to load my monitor model form inf file that I downloaded from BELINE site?

Are you using the open-source radeon driver or the proprietery fglrx driver?

Post your xorg.conf here, then it is easier to cut and paste required changes. You will need to edit it with root privileges. I find it preferable to use a CLI editor like pico or vi for this job. At the very least you will need to add a modeline to ‘Modes’ section like this:

Modeline “1280x800” 107.21 1280 1360 1496 1712 800 801 804 835 -HSync +Vsync

It may be necessary to make other changes as well, including adjusting refresh rate range in the ‘Monitor’ section, and maybe diasble EDID in the ‘Device’ section as well. (This can be explained later if required).

This is my xorg.conf:

# /.../
# SaX generated X11 config file
# Created on: 2009-06-15T01:49:54+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AIGLX" "on"
  Option       "AllowMouseOpenFail" "on"
  Option       "IgnoreABI" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "glx"
  Load         "extmod"
  Load         "freetype"
  Load         "dbe"
  Load         "dri"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "rs,us"
  Option       "XkbModel" "geniuscomfy"
  Option       "XkbOptions" "grp:alt_shift_toggle,lv3:lwin_switch"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "latin,basic"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "7"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Darfon Electronics USB Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  337 270
  HorizSync    31-83
  Identifier   "Monitor[0]"
  ModelName    "BELINEA 1705 S1"
  Option       "PreferredMode" "1280x1024"
  VendorName   "MAX"
  VertRefresh  56-75
  UseModes     "Modes[0]"
EndSection

Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x1024" 108.00 1280 1328 1440 1688 1024 1025 1028 1066
EndSection

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Section "Device"
  BoardName    "ATI Radeon 9550 / X1050 Series (RV350/RV360 4153)"
  Driver       "fglrx"
  Identifier   "Device[0]"
  Option       "SaXDualHead"
  Option       "XAANoOffscreenPixmaps" "true"
  Option       "Capabilities" "0x00000000"
  Option       "SaXDualMode" "Clone"
  Option       "ForceMonitors" "auto,crt1"
  Option       "SaXDualHSync" "30-83"
  Option       "SaXDualMonitorModel" "BELINEA 1705 S1"
  Option       "SaXDualVSync" "50-75"
  Option       "VRefresh2" "50-75"
  Option       "Mode2" "800x600,768x576,640x480"
  Option       "FSAAScale" "0"
  Option       "FSAAEnable" "off"
  Option       "VideoOverlay" "on"
  Option       "SaXDualMonitorVendor" "MAX"
  Option       "HSync2" "30-83"
  Option       "DesktopSetup" "Clone"
  Option       "SaXDualResolution" "800x600"
  Option       "SaXDualOrientation" "Above"
  Screen       0
  VendorName   "ATI"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection


What changes I suppose to do there?

Do you have a disk from Bellinea? If so, start System - Configuration - Sax2, Change Configuration - Monitor properties, look for “Utility disk”, click it, insert CD in drive, click OK, OK, OK, Save and exit. Now logging out and in again should give you the proper resolution.

Try Knurpht’s advice if possible. However, if you don’t have a disk for your monitor, I’m not sure how to point YaST to the inf file. (I guess you could burn it to CD first)?

You can use the Xorg utility ‘gtf’ to generate a modeline for 1280x1024 @75Hz:

dean@linux:~> gtf 1280 1024 75

1280x1024 @ 75.00 Hz (GTF) hsync: 80.17 kHz; pclk: 138.54 MHz

Modeline “1280x1024_75.00” 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync

Then you add it to your Section “Modes” like this:

Section “Modes”
Identifier “Modes[0]”
Modeline “1280x1024” 138.54 1280 1368 1504 1728 1024 1025 1028 1069 -HSync +Vsync

EndSection

If necessary, you can disable EDID with the following option in Section “Device”:

Option “IgnoreEDID” “yes”

Thats about all I can offer.