OpenSUSE boots in unsupported screen resolution

I have just installed a dual boot setup with OpenSUSE and windows. When the OpenSUSE partition loads, it gets past the loading menu and then enters a screen resolution that’s not supported by my monitor.

The live CD uses a resolution that’s supported, but I can’t mount my hard drive. The safe boot also boots into the unsupported screen size.

I really want to try out linux but so far fails on even to boot. How do I change the resolution when I can’t get into it?

Tell us if you are using KDE or Gnome.
Tell us what you have as Graphics card.
Tell us what monitor and resolution it requires.

Gnome/ ATI Radeon 9600 X1050/ acer widescreen 19" (plug n play) monitor.

Fairly recant hardware. It works perfectly on the live CD, so it should be compatible.

You might want to consider - in the future - use the DVD for install.

Anyway, put these links somewhere
NEWBIES - Suse-11.0 Pre-installation – PLEASE READ - openSUSE Forums

They will come in handy.

Now re-boot
At the green boot screen you should have the default boot, failsafe and perhaps debug.
Use the up/down arrows to pause the timer on the boot process.

Now move back to the default boot.
What text, if any is shown lower down, it might say vga=???

Is the vga=??? the same number in the failsafe (failsafe will have lots of text)

Try deleting the text in the default. Boot. See what happens.

or replace with: vga=0x31a

Default boot has vga=0x31a. Changing it to nothing only changes the loading screen resolution, and using x11failsafe boots to a console.

try this

at boot screen type 3 in the boot line to get runlevel 3 - login as root

sax2 -r -m 0=vesa


Thanks for that caf4926, now it boots. However now its max screen size is 800x600 (really hard on the eyes) and it can’t change to another resolution (it does, but after it says it needs to reboot and goes back, and upon reboot it stays the same).

Also firefox can’t surf the web. I can ping people via console but firefox won’t load a page… is there way to fix that?

Use Yast to configure your networkcard

You need internet to do the rest

I’m off out now, maybe someone else will come in.

This sounds like the old video bios problem. If the BIOS is not reporting your monitor correctly, then the installer will just take a guest and get it wrong.

In YaST > Software Management look for a package called 915resolution to see if it is loaded. If it isn’t, the install it and then look here - 915resolution: Intel Video BIOS Hack & here - It’s worked on all the Linux boxes I’ve built so far.

I have exactly the same hardware! I installed opensuse 11 from the DVD and it works fine! :slight_smile: Except it got the inches wrong, I had to take it down an inch in sax2.

From what I know I have an ATI Radeon 9600 XT card, An Acer Widescreen 19" Screen and I’m using GNOME. My motherboard is an ABIT IS7 series.

Ive never used the live CD. Did you install from the live CD?

I installed from a liveCD, thats when all the problems started. I’m using OpenSUSE now, I solved my problem by creating a new user and deleting the default liveCD user. There are still some other problems, like I can’t communicate to the Internet using ssh. But over all I’m happy with the result