OpenSUSE boot problem

Hi, I’m new to openSuse, I installed 12.3. I was navigating around trying to become familiar with the file tree (cofiguration files, var, etc and some other files. I don’t know if I changed something. I have a partitioned computer, which runs windows XP and put OpenSuse in the partition.

OpenSUSE will not boot now after I went looking around at the files. It boots the grub, then it gives the option to boot to windows or opensuse. Windows boots fine, when I boot to opensuse I just get a screen with the cameleon on it, nothing else.

If I press escape a list of the files it has loaded comes up.

It says: Failed to start network manager
Dependency failed for network manager.
Failed to start lsb: virtual box Linux addition kernel modules.

It has a list of thing it says is [OK].

the final one that is [OK] is: Reached target Graphical Interface.

Any help would be much appreciated.

If someone can help

Your explanation is a bit vague

How did you install again? With more detail please. It sounds like you may have installed from Windows but it is unclear openSUSE normally installs to 3 partition swap/root/home

Well, maybe there’s no network configured?
But let’s keep that for later. The system should boot despite this message.

Failed to start lsb: virtual box Linux addition kernel modules.

This is normal, as you don’t run openSUSE inside VirtualBox.
You could uninstall “virtualbox-guest-kmp-desktop” (or similar) to get rid of this message, but again something for later.

It has a list of thing it says is [OK].

the final one that is [OK] is: Reached target Graphical Interface.

This looks like a graphics driver issue.
What graphics card do you have?
Did you install any additional driver?

Try to select “Recovery Mode” under “Advanced Options” in the boot menu (where you can choose whether to boot openSUSE or Windows f.e.).
Do you get a graphical system then?

The graphics card is a NVDIA GeForce GO 7300.

I tried booting into safe-mode and it’s the exact same, just a blank desktop screen with nothing on it, no link to the activities, no tray at the bottom. Just a picture of the chameleon on the branch.

I don’t have a network configured on it, except the internet. Opensuse gnome 12.3, isn’t running virtually; I partitioned my computer, originally just running windows xp, and have Opensuse running in the partition. I have had the computer running like that since October/November 2013.

I’ve tried putting in the opensuse CD again and have reinstalled the linux kernel twice now - I think. I know I shouldn’t have. :slight_smile: I was hoping to find a way to just reinstall the opensuse back to the original. I don’t have very much on it yet so I wouldn’t be loosing much. I’d prefer not to have to obviously.

Thanks for the help.

In that case, I would suggest you try to install the proprietary nvidia driver.
Especially GNOME3 is a bit picky with the drivers, as it absolutely requires OpenGL support.

Try to add “nomodeset” to the boot options (see below) as a first step, does it work then?

When the screen is just black with a mouse pointer, try to press Ctrl+Alt+Backspace twice, do you get to a login screen?

I don’t have a network configured on it, except the internet.

Well, but the Internet is a network connnection, isn’t it?

How do you connect to the Internet? (via cable or wireless f.e.)
If it’s a cable connection, it should work out of the box even in text mode, that would make it easier to install the driver.

In that case, add “3” to the boot options to boot to text mode. If it is grub1 you can just enter “3” at the boot menu. For grub2 you have to press the ‘e’ key, append “3” to the end of the line starting with “linux” and press ‘F10’ to boot.

Then log in with the username root and your normal password.
Run yast, select Network Settings->Network Devices, switch to ifup in “Global Options” and setup your network card if necessary.
Select “Software Repositories”, “Add”, “Community Repositories”, and add the NVidia repository.
Then enter “Software Management”, type “nvidia” into the search field, and install the packages x11-video-nvidiaG02, nvidia-gfxG02-kmp-desktop, and nvidia-computeG02 (the latter two should be selected automatically)
Then the system would hopefully boot.

If that doesn’t help, or you don’t have a Internet connection in text mode (you could try to set it up with yast though), I would suggest to try one of the following:

  • Install 13.1 instead, the newer kernel and nouveau driver might work better on your system
  • Re-install 12.3, but choose something else than GNOME. Other DEs might start just fine without any additional driver.
    You can always add GNOME later on when your system is up and running, preferaby with the nvidia driver.

PS, before you do a re-install:
Just to clarify:
Is this a fresh installation of openSUSE 12.3, or did it run already but suddenly stopped working?