openSUSE asking authentification when connecting to Internet

Hi, newbie here.
Just installed openSUSE 12.1 x86_64. I first connected to Internet via LAN since I wanted to see if it worked and if there was already a wireless driver installed (I don’t know if b43 or b44, my card is Broadcom and b43 was used by 11.3…). So at least web browser worked, but several times suddenly appeared an authentification request message from root “to modify network proxy used to download packages”. When displaying Details tab I find the action is Set Network Proxy and the vendor is The PackageKit Project. The message used to show up and disappear, but later it did not disappear at all, unless I closed the window or typed my password.

What is this message about? Could it be for openSUSE updates or something like that? And what wireless driver does the new kernel use?

I suggest you check out this message as Linus himself has a problem with this one. Be sure to follow the links …

Now I have on occasion for the update icon asking for a password, but wireless seems to addin another dimension to the problem.

Thank You,

I think it would take me a big while to understand every detail of that. For now I had to disable Apper from Personal Settings.