OpenSUSE and X.Org 7.7

Hello All,

I’m having troubles with my graphic card and I already think it is connected with the version of the X.Org used by OpenSUSE (it is 7.6). How can I install 7.7 version? Is there only the way to compile it from source?

You can install the latest Xorg 7.6 (xserver 1.15.99), Mesa 10.1 and the latest drivers from this repo:

You should add the repo and do a full vendor change update, see SDB:Vendor change update - openSUSE Wiki.

But why do you think you would need X.Org 7.7?
The graphics drivers are separate packages with different version numbers anyway.

What graphics card do you actually have?
And what troubles do you have?

You should specify your openSUSE version, too.

I have 13.1, but also tried tumbleweed. By the way I also tried other linux distributions…

I have Intel HD 2000 on i5. Computer is new and was working properly half a year. But then screen started to freeze. I have no windows distro, so don’t know if the problem appears only on linux.

show_signal_msg: 96 callbacks suppressed
Watchdog[4200]: segfault at 0 ip 00007f66422dc51e sp 00007f663256d680 error 6 in chrome[7f663e85e000+5ddb000]
[drm] stuck on render ring
[drm] stuck on blitter ring
[drm] GPU crash dump saved to /sys/class/drm/card0/error
[drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[drm] Please file a new bug report on against DRI -> DRM/Intel
[drm] drm/i915 developers can then reassign to the right component if it’s not a kernel issue.
[drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it

This is the error message. I googled but none of the solutions helped.
Now I have temporary solution to try to close the app where this error occured (it may be any app starting with chrome and ending with netBeans). When screen freeze I click on the close button and wait. Some times it helps)))

See if this earlier thread helps, particularly if you use KDE.

In this case I would recommend to try this first:

And did you install all updates? (check in YaST->Online Updates f.e.)
Some crashes in the intel driver have been fixed after release.

If that doesn’t help, you could try the latest Xorg/Mesa/intel driver as described in my previous post.
The latest kernel might also help:

Edit: Before you upgrade, better try first what nrickert pointed to. :wink:

always switching this off, because my screen does not support dimming. but unfortunatelly that is not the issue :frowning:

For now I’m running Tumbleweed, so I think I’m up-to-date. I will try the solution with switching render mode. Never met this before. :slight_smile:

The new SNA acceleration is only enabled by default since openSUSE 13.1.
But as it is quite new it still has problems with specific chips.

I hope it will help.

no problems so far.
thank you, wolfi232!:slight_smile: