Opensuse 42.3 und LinuxMint 18.3 fail to install on Lenovo MIX 320-10ICR

My new Lenovo MIIX 320-10ICR came with Windows 10. As on my other computers I wanted to install Linux as a dual boot.
After seeing the installation options (in Suse and Mint) the screen freezes or turns black respectively.

The Graphic Card is Intel HD Graphic Card VGA-
I tried to find a Linux Driver and even contacted Intel but did not get an answer. :’(

Does somebody have a solution?

At the grub screen press e to edit and on the line starting with linux (or linuxefi) add;

nomodeset i915.modeset=1

Press F10 to boot and see if that helps.

Thanks for your your reply malcolmlewis,

I followed your advice and the screen again freezes at the echo “Loading Kernel … Loading initial ramdisk”.
The USB install medium keeps blinking busily - so something is still happening, but not on my screen!

My suspicion is that it’s a graphic driver problem.

I’m sure it is a graphics driver. I would suggest downloading a Tumbleweed live release and try that;

The other option maybe to try a net install of 42.3 rather than the DVD.

Ran into the same problem recently with an install on someone else’s laptop that I do not have access to right now.

Not certain, but I think I may have solved it simply with adding:


and not the additional i915 command.

Try it.