Opensuse 42.3 Installation Screen freezes after "Loading initial ramdisk... "


I an trying to install Suse 42.3 on my new Lenovo Miix 320-10ICR. But each time the installation screen freezes after "Loading initial ramdisk… ". I had the same problem with Linux Mint.

On a Lenovo Forum I was advised Ubuntu 17.4 for atom processors which installed without problems. However I just cannot put up with Ubuntu (some functions like sound and battery monitor also don’t work).

I tried Boot Commands like “nomodeset” and “Textmode=1”, no success.

The EFI/boot of Ubuntu 17.4 contains a file with the name of “bootia32.efi” which 42.3 doesn’t. Is that the difference?

Thanks in advance

Not very sure, maybe a better expert should confirm this, but AFAIK many (all?) Atom processors need a 32 bit EFI launcher that openSUSE doesn’t provide; so apparently the missing bootia32.efi is indeed your problem.

OOOps! There are some newer Atoms that support the 64 bit instruction set, like the Atom-x5-Z8350 that might be inside your Lenovo Miix 320-10ICR.
So maybe your problem might be different…

Some more grub2 commands you can try

Apparently you may also need to verify Bitlocker is not enabled.

On second thought, your error might be happening before grub2 is even loaded.
You may need to first see if you can boot off a USB stick (ie a LiveCD) to verify your hardware BIOS has no problems with an openSUSE in general…


Was it running 32-bit or 64-bit Windows?

It may be that, there’s a UEFI/BIOS setting for 32-bit or 64-bit Windows . . . :wink:

Sorry, overlooked those answers. Believe it or not, I am still not one step further with the issue.:’(
Could install Ubuntu on the machine, but this is not what I want.

What is Bitlocker?

How do I find out, whether the hardware BIOS has a problem with openSuse in General?

Best Regards



How do I get a 32 bit EFI launcher for a 64 bit machine?

Best Regards