Opensuse 42.2 update/rescue system does not complete, sticks at message "Loading basic drivers..."

I try to upgrade opensuse 42.2 (or to run the opensuse 42.2. rescue system) but it doesn’t work. This is what I did.

  • download iso image
  • make a bootable usb stick
  • boot from usb stick
  • this works, I choose (e.g.) “update” or “rescue system”
  • something happens, messages on the screen
  • then the green bar at the bottom of the screen appears, with at the right “opensuse 42.2”
  • this bar grows and grows, the three different green colors are going towards the right side of the screen, nothing happens any more
  • if I press any key, I see the message “Loading basic drivers…” at the top of the screen but it seems to stick, the update or rescue system never continues.

I tried this on two different computers with the same result.

I tried F3=text mode, same result
I tried F5=safe settings, same result
I tried F5=noacpi, same result
I tried “nomodeset” as kernel parameter, same result

[side note: I also tried to boot from the usb stick in a virtualbox virtual machine and that works, so the usb stick seems to be correct.]
[side note: I have made a bootable usb stick from opensuse 42.1 the same way and that one works]
[side note: this concerns the released version of opensuse 42.2, downloaded on Nov. 18]

Any hints?

Thanks a lot!

Possibly a misunderstanding:

  • The openSUSE DVD (or USB) ISO image includes a “Rescue System”, which is meant to be used for repairing an openSUSE system installed on a hard drive.

Therefore, it cannot “repair itself” – it will go looking for a system installed on a hard drive and, if it can’t find anything it’ll possibly continue looking until (possibly) a timer expires.

Can you check if the “Rescue System” in fact times out?

If a timer is present, you will have to wait several (at most 30) minutes before the timer expires with hopefully a message such as “No installed system to repair found”.

If it never times out, please raise a Bug Report to get this issue repaired.

Thanks for your reply.

I tried both choices, “update” and “rescue system” to find out if one or the other would work, but neither of the two options either continued to the update or the rescue system.

I only waited for about 5 minutes, I will try waiting longer to see if something happens. I will get back on this. I didn’t know I had to wait for at most 30 minutes.

(note that if I choose the “rescue system” option in opensuse 42.1 on usb stick, it starts the rescue system almost right away, after about 30 seconds, I use it on a regular basis to back up my opensuse 42.1 installation).

Did you check the md5sum ?

Yes I did, thanks

Hardware: AMD A10-5750M APU with Radeon™ HD Graphics – 8 GB RAM – Lenovo G505s Laptop – dual-boot to Windows 8.1.
Installed Linux is openSUSE Leap 42.2 in an ext4 partition on /dev/sda10.

Did the “Lenovo G505s required” things: turned off UEFI Secure Boot and moved the DVD-D drive to the top of the BIOS/UEFI list.

Booted the DVD ISO and checked the following:

  • “More” -->> “DVD Check”: tested OK.
  • “More” -->> “Rescue system”: tested OK – Linux partition mounted OK; swap and Microsoft partitions refused to mount.

You may have a hardware dependent issue; can you please tell us which hardware is displaying this behaviour?
It’s a little bit strange that previous openSUSE Releases were not displaying this behaviour

Was Windows shut down properly ie fast boot turned off?

update? 42.2? is 42.1 already installed and still working?
to me it’s not all that clear, just what you are trying to do?.. why rescue?
the DVD iso works… so, what is really the issue?

Thanks for your replies.

It seems that two different issues are going to be mixed up in this thread. I started it with message #1.

  • I tried to start a “rescue system” with opensuse 42.2 to see if I could get to the root login prompt, just to see if that was working, but it didn’t start.
  • I tried to do an “upgrade” because I want to update my opensuse 42.1 installation, but that didn’t start either (for details see message #1).
  • the DVD messages in #6, #7 and #8 seem not relevant for my issue since I am booting from a usb stick.
  • #6: I have tried this on two of my computers: one is a self built Intel I5 and the other an Intel NUC NUC5PPYH (, both have opensuse 42.1 and both have the problem in message #1.
  • #8: Yes, I have opensuse 42.1 working and I to upgrade. I don’t use a DVD, I use a usb stick with the ISO download. The issue is that I cannot upgrade.

Thanks again!

Then, it seems that a Bug Report against the Leap 42.2 YaST Rescue System needs to be raised for your specific hardware configuration.
Please raise the Bug Report here: <> (your Forums login also allows you to access the openSUSE Bugzilla system).

Ok, this is what I found out. For updating both of my systems, I had to wait for about 35 minutes before the “update” started after booting opensuse 42.2 from my usb stick. On both systems I have succeeded in updating to opensuse 42.2. So the problem (well, my problem :slight_smile: ) is in the long time out. For updating a system a long time out is acceptable, but if I need to use the “rescue system” in case something goes wrong with my system I would also have to wait for 35 minutes before being able to rescue something (and then again 35 minutes when I need to reboot, etc.). This would be really annoying.

When I use my usb stick with opensuse 42.1 the starting of the “rescue system” only takes 1 or 2 minutes from booting the stick, on the same hardware configuration on both of my two computers with the same usb stick. It seems that something has changed in the “Loading basic drivers…” step of booting of the usb stick.

This is my hardware:

Should I file a bug report? If so what info to include? Would it help?

Thanks for your help!

Yes, please file a Bug Report.
Please mention that the Intel “Next Unit of Computing” (NUC) {Sandy Bridge Celeron} is affected.
Please also mention that the Intel I5 is affected – please add a more detail about you I5 system: Mainboard, Chipset and Video (Card, onboard GPU).

It is here:

I hope I can help.
I had the same problem when booting from a USB stick inserted in a USB hub and the problem in my case was solved inserting the stick directly in a USB port of the desktop PC.

… and also try moving to a different port on the PC, if you are already using a port directly.