Opensuse 42.1 leap - No sound in LibreOffice Impress

In Opensuse 42.1 Leap, when I run a slide presentation with imbedded audio, the audio does not play :(. This is despite me having installed all of the codecs through one click install. I have tried the slide presentation in other Linux OS and had no problem with the audio.
I appreciate any advise as how this could be corrected!

Welcome Marco, you are not alone: I don’t remember sound ever working in LibreOffice Impress on OpenSUSE (at least on my HW), while it worked with OpenOffice, even a recent Apache version the last time I tried.
That at least should save your day, if nobody else comes up with a better fix.

Thank you for quick reply!
This is a shame that despite Leap being based on enterprise system not being a perfect OS. I wonder how those companies or corporation who may be using the enterprise system get along when they need to have presentations with embedded audio.

Well. Guess what folks! Today there were a bunch of updates-upgrades packages mostly codecs. Upon completion of download and installation, I tried, like usual, the impress with a slide presentation. Bingo! the audio started playing and made me happy :). This was a great surprise lol!.
Kudos to the developers! Nice job!

Hi Marco , which sounds are you referring to? Slide transition sounds?
Custom animation sounds are still broken AFAIK. The problem has been known for years upstream, see for instance the following bug reports, still open:

Sorry for late response. I was out of town.
First, my problem, as I described in the OP, was that I had a bunch of slide presentation files with each having embedded audio. namely musical themes, which would not play when the presentation was run. This issue was resolved by latest codecs upgrade, as mentioned in my last post.
Second, I tried the attachments in your bug report links. The attach files did not work in my stock Libre Office Impress either. But I noticed that the bug reports were for LO version 4.x, whereas I have LO 5.x. Then I tried a few audio test files from the LO gallery to test. They all played well.
Finally, I noticed while playing a test audio from Gallery, when I did a File/close, there was no reaction at all and the file kept on playing. It seems that the menu options under this case in LO were not responsive. By closing the application with a click on the X on the right top corner, the LO does not open from the main KDE menu again before a power of-on.

Never mind Marco, this is just for forum readers that might be interested.

Unwisely, OpenOffice / LibreOffice use “absolute” file paths to sound-effect files in the Gallery, so whenever you move or download a file or even when you change application version you have to refresh each reference to sound effects in your presentation before hearing something (even when it works…).
That said, even with that annoying workaround, I re-checked everything on** Leap and LO **and found the following.

  1. Sound samples from Gallery work, but the Media Player has very looooong response times (as you found).
  2. Sounds from Gallery associated with slide transitions work.
  3. Sounds from files embedded in the presentation work (if you have the right codec installed: this seems your case as I understand it).
    4) Sounds associated with custom animations STILL DON’T WORK (as written in the attached bug reports); at times you might hear clicks or “burps”, signalling that the sound pipe is somewhat “active”.

I also checked the current Apache OpenOffice Impress 4.1.2 and found NO WORKING SOUND whatever I tried.

Those seem to be Linux-specific bugs, so maybe the Win versions work to some extent.