openSUSE-2020-890 (1) update fails

Hi folks;

Any ideas as to why the openSUSE-2020-890 (1) update fails on me? I get the error message:

**icewm-1.4.2-lp151.8.6.1.x86_64 requires icewm-theme-branding, but this requirement cannot be provided **

but as far as I can tell, everything with icewm is installed. Can you point me in the right direction?

Thank you!


I just saw the same doing YaST > Software > Online Uodate.

I guess it is a glitch. Better wait a bit until it is fixed. You can also uncheck the icewm patch (it is not a security one, but recommended) and install the others.

I read that thread, but it is not clear to me that it is solved, regardless of what post #17 there says. That looks rather like a by-passw at most.

And I (and the OP here ) got the message just a few hours ago, thuis IMHO it is not solved.

Or do I miss something?

The problem is not resolved yet. Solution in the other thread: “delete icewm-config-upstream” causes icewm to be completely removed. This isn’t a solution. I haven’t been able to look at the bugzilla page, I’m still not able to log in, I might just have to set up a new account. Be that as it may, I’m hoping someone sees the bug and takes care of the problem. Zypper up until them.

Bugzilla was down for a while today – apparently for maintenance. But it is up now. Your forum login and password is supposed to also work to login to bugzilla.

Thank you, nrickert, that was the first time that I’ve been able to log on to bugzilla since the transition. I hope it stays that way.

BTW - Bug 1173441]( - icewm update cannot be installed - is still unresolved. There was a link to a solution to a similar issue, but, I’m getting a: We can’t connect to the server at to take a look at it.

I guess zypper up will suffice until it’s fixed.

Thanks again

That should be fine.

Solution in the other thread: “delete icewm-config-upstream” causes icewm to be completely removed.


zypper se -si icewm
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                 | Typ   | Version           | Arch   | Repository
i+ | icewm                | Paket | 1.4.2-lp151.8.6.1 | x86_64 | OSS-Update
i+ | icewm-default        | Paket | 1.4.2-lp151.8.6.1 | x86_64 | OSS-Update
i+ | icewm-lang           | Paket | 1.4.2-lp151.8.6.1 | noarch | OSS-Update
i+ | icewm-lite           | Paket | 1.4.2-lp151.8.6.1 | x86_64 | OSS-Update
i  | icewm-theme-branding | Paket | 1.2.4-lp151.3.6.1 | noarch | OSS-Update

The history:

2020-06-28 17:50:05|install|icewm-config-upstream|1.4.2-lp151.8.6.1|noarch||repo-update|437db75195ec0b8cd35917ee369ab6fb67c7b96b6567675c35c29a17493de02b|
2020-06-28 17:50:05|install|icewm-lang|1.4.2-lp151.8.6.1|noarch||repo-update|afb6f12a5fb29bdab2546225e064a6475390be71e5d172c675cb2a0d1a5ac1f3|
2020-06-28 17:50:05|install|icewm-lite|1.4.2-lp151.8.6.1|x86_64||repo-update|cc9ca91e05aab31801b50121a7354d7766402cd24eae9d4628a044d709c226a9|
2020-06-28 17:50:06|install|icewm-default|1.4.2-lp151.8.6.1|x86_64||repo-update|2e300fe1ca7c70bac2cc4799382b779a0442f2dd899d009d9612cb8ae021fd13|
2020-06-28 18:11:17|install|icewm-theme-branding|1.2.4-lp151.3.6.1|noarch||repo-update|72b4d336e0d51bdf73446bef3c59ea3053cd88cfc0e3b0f825b06d787379f48f|
2020-06-28 18:11:17|install|icewm|1.4.2-lp151.8.6.1|x86_64|root@linux64|repo-update|9c216c697a569850199e0dbe91961eaa47ded921a564d05ae1f62b59d269d980|
2020-06-28 18:11:17|remove |icewm-config-upstream|1.4.2-lp151.8.6.1|noarch|root@linux64|

Only icewm-theme-branding was installed and icewm-config-upstream was deleted.

Thank you all for your help. I’ve removed icewm-config-upstream, which has alleviated the symptoms (but not, evidently, solved the underlying problem).

I really appreciate your tips.