openSUSE 2017-987-1 Security update for Samba and Resource agents - Fails to install

G’day folks,

This update fails to install on my machine with the following error :

samba-libs-4.6.7+git.38.90b2cdb4f22-3.1.x86_64 requires, but this requirement cannot be provided

When I open YAST and look at my installed software it appears that I have pytalloc_util_2.1.6-1.4 installed.

Can someone please tell me how I go about having pytalloc_utill_2.1.9 installed so I can meet the requirements of this patch?


Hi and welcome to the Forum :slight_smile:

Use zypper and the command line…

zypper -vvv ref -f
zypper -vvv up

The mirror brain redirection may also be pointing at an incomplete mirror in your locale, both samba-libs and python-talloc at the right versions installed here fine.

Thanks very much for the prompt reply and assistance,

I executed the commands and tried the update but I’m still getting the same error as before.
Anything else to try or do I just wait for change on the mirror in my location?

Well it may/maynot, if you add more verbosity to the commands -vvvv or -vvvvv do you see the mirror you getting pointed at for the files?

If you look at the following URL’s do the same locations appear?

No, I’m sorry to say I don’t see the mirrors in the output.

Yes, when I look at those URL’s I do see the same location.

Hmmm, well if you go into YaST Software Repositories and select a mirror that’s in your locale and use that and see how it goes, eg for here in the US I could change if from;


Everything is good again,
thank you for your assistance good sir!