OpenSUSE 13.2 x64 - AMD fglrx Issues

Due to the dual processor, my laptop screen requires that I unify outputs to align the messages and programs on the screen. Having said this, if one does not install the AMD fglrx drivers first, the screen goes completely black on startup, and one must enter “recovery mode” and install the AMD fglrx drivers to resume normal function.

Going to the AMD fglrx page (https://en.opensuse.org/SDB:AMD_fglrx), one can manually install or use the 1-click install option. The 1-click install option now works for OpenSUSE 13.2, yet if one installs the fglrx drivers this way, or manually, one can no longer use the “Online Update” feature in OpenSUSE 13.2 to install/uninstall software. Also, automatic detection of printers after this installation fails.

I have reinstalled the OS a bunch of times testing these outcomes, and every single time this happens, including these strange, seemingly unrelated issues. The only solution that seems to work is if one manually installs the core component, and only the core component (http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.2/x86_64/fglrx64_core_SUSE132-14.501.1003-1.x86_64.rpm). I have used the 1-click install in this latest instance, which installs the entire set of drivers. How do I get the system working properly again with the complete set of drivers installed?

On Sun, 04 Jan 2015 00:06:07 +0000, BMor wrote:

> yet if one installs the fglrx drivers this way, or manually, one can no
> longer use the “Online Update”
> feature in OpenSUSE 13.2 to install/uninstall software. Also, automatic
> detection of printers after this installation fails.

There’s no reason this should cause a problem - when you say something
fails, it would be useful to have exact error messages rather than a
generic description like that. Generic descriptions can’t be diagnosed -
exact error messages can.

If you need to, launch the utility in question from the command line (a
terminal window) to get an error message if none is produced.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

I would have provided the error message if one was produced. The GUI for the online update noticably stops working every single time the fglrx drivers are installed from the aforementioned site. Yast can still be launched via the terminal. From here, repositories can still be added or removed, software can still be installed or deleted, etc. The GUI frontend for this feature; however, no longer works after the fglrx packages are all installed. I try to launch the application. I get the expected “run as root” password box. Yet after I enter the correct password, nothing happens. No error message is produced and nothing noticeable further happens to the system. The only work-around I found so far was to manually install the core package as mentioned above, installing no other packages. Would there be a diagnostic utility I can run that can provide a little more information as to why the GUI frontend fails in this instance?

Ok the GUI does not works at without the fglrx driver right?? What video chip? AMD drops older chips rather frequently. Also What Desktop?

When it works some programs notably some form of installer does not work? Right?

You have not tried to start the program(s) that cause problems from the command line to see if they spit out some error messages? right? Why not??

It all works if you only install the core. So again what chip??

On Sun, 04 Jan 2015 04:06:01 +0000, BMor wrote:

> The GUI for the online update noticably stops working every single time
> the fglrx drivers are installed from the aforementioned site.

Define “stops working”.

Remember that nobody here knows what you know about your system, or is
seeing what you’re seeing on your system.

You say Yast can be launched via the terminal (which sounds like you’re
running it from a console, not from, say, gnome-terminal or konsole).
You can launch it there as well, using kdesu or gnomesu (as appropriate),
and you should get (a) a gui, and (b) messages in the terminal window
that show what’s going wrong.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

If I understand correctly, from the command line the program is Yast, which I did run. I can interact with Yast via the Konsole (which I was referring to as the “terminal”), but not the interface that allows for one to select and delete software via the mouse (which I was calling the GUI program).

Sorry, the above message was accidentally sent before complete.

If I understand correctly, from the command line the program is Yast, which I did run. I can interact with Yast via the Konsole (which I was referring to as the “terminal”), but not the interface that allows for one to select and delete software via the mouse (which I was calling the GUI program). My machine is old, a Lenovo T500. The card on it is a Intel GMA 4500 MHD ATI Switchable 256MB graphics card. If AMD drops cards frequently, this could be the problem. The system is approaching its 6th year. I am running OpenSUSE 13.2 x64 with the KDE platform.

In reponse to Mr. Henderson:

 I took your advice and downloaded *kdesu* via Yast running in the Konsole.  I ran the command *kdesu yast*  which brought up the GUI root password box - the same as what would  happen if I clicked on the program.  The line indicator drops to the  next line after executing the command, which is expected when running a  program from the Konsole.  No error message is produced in the Konsole;  however.  I look at the Konsole and it appears as if the program is  running, yet no GUI appears on screen for this specific program.  So  far, running any other program in the Konsole brings up the GUI.  It  seems restricted to just this program.  I wish there was something more I  could provide.  Any further suggestions?

I took your advice and downloaded kdesu via Yast running in the Konsole. I ran the command kdesu yast which brought up the GUI root password box - the same as what would happen if I clicked on the program. The line indicator drops to the next line after executing the command, which is expected when running a program from the Konsole. No error message is produced in the Konsole;

Instead, try

su -c /sbin/yast2

or

/usr/bin/xdg-su -c /sbin/yast2

I took your advice and downloaded kdesu via Yast running in the Konsole. I ran the command kdesu yast which brought up the GUI root password box - the same as what would happen if I clicked on the program. The line indicator drops to the next line after executing the command, which is expected when running a program from the Konsole. No error message is produced in the Konsole; however. I look at the Konsole and it appears as if the program is running, yet no GUI appears on screen for this specific program. So far, running any other program in the Konsole brings up the GUI. It seems restricted to just this program. I wish there was something more I could provide. Any further suggestions?

You need to understand that ‘kdesu’ is for running graphical applications with root privileges, and ‘yast’ is a ‘text-mode’ (ncurses) application, so this won’t work. You need to use ‘yast2’ to launch the graphical version of the YaST utilities.

 /sbin/yast2 --help
Usage: /sbin/yast2 [OPTIONS] [MODULE] [module specific parameters]

OPTIONS:
        -h, --help      this message
        -l, --list      list all available modules
        --qt            use the QT graphical user interface
        --gtk           use the GTK graphical user interface
        --ncurses       use the NCURSES text-mode user interface
        -g, --geometry  default window size (qt only)
        --noborder      no window manager border for main window
        --fullscreen    use full screen

On Mon, 05 Jan 2015 09:26:02 +0000, BMor wrote:

> It seems restricted to just this program. I wish there was something
> more I could provide. Any further suggestions?

Nope, it’s the path. Try:

kdesu -c ‘/sbin/yast2’

I often forget that it’s not in other peoples’ path because /sbin/ isn’t
in the normal user path.

You would have the same issue if you launched it outside a terminal.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Not quite - he was trying to launch ‘yast’, rather than ‘yast2’), so

kdesu -c yast2

should work okay as well. Does for me (and I don’t have /sbin in my user path either). Using ‘kdesu’ takes care of that.

On Mon, 05 Jan 2015 20:46:01 +0000, deano ferrari wrote:

> hendersj;2687406 Wrote:
>> On Mon, 05 Jan 2015 09:26:02 +0000, BMor wrote:
>>
>> > It seems restricted to just this program. I wish there was
>> > something more I could provide. Any further suggestions?
>>
>> Nope, it’s the path. Try:
>>
>>
> Code:
> --------------------
> > > kdesu -c ‘/sbin/yast2’
> --------------------
>> >
> Not quite - he was trying to launch ‘yast’, rather than ‘yast2’), so
>
> Code:
> --------------------
> kdesu -c yast2
> --------------------
>
> should work okay as well. Does for me (and I don’t have /sbin in my user
> path either). Using ‘kdesu’ takes care of that.

Interesting. With gnomesu, I have to specify the path if my user doesn’t
have /sbin in the path.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Tried the code you provided. Password box appears as before, but still no GUI interface. The only thing different is that in the terminal, after executing the code, the terminal window drops down one line and will accept a new command. Perhaps the fact that I am running this on an old machine with an almost 6-year old AMD card, the fglrx driver might not be entirely compatible. This is the only consequence (the only one I found and that is consistent) that seems to arise from it. I think I might as well just install the core component only and ensure I only get Intel Graphics when I purchase a new machine.

To everyone, thank you for all of your help. I learn a bit more about the OS everytime! Much appreciated.

On Tue, 06 Jan 2015 05:26:01 +0000, BMor wrote:

> To everyone, thank you for all of your help. I learn a bit more about
> the OS everytime! Much appreciated.

Which specific card is it that you have? You may be correct that it’s
not supported by the Catalyst driver, as that tends to be the case.

But what you’re seeing doesn’t really make that much sense to me - if you
want to keep diagnosing, that’s cool - and if not, that’s cool too. But
it would be nice to see if we can track down what’s going wrong here.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Try to run “xauth -b” (as user) and then enter ‘q’ in a terminal. Does it work then maybe?

And please post the file /var/log/Xorg.0.log. This should show whether the fglrx driver is actually in use and working.
It only supports HD5000 cards and up.

Hi, I’ve a HP laptop with Intel processor + AMD GPU and 64-bit OpenSUSE 13.2 KDE. The first time I install fglrx, I got to some fallback GUI mode then every time I try to install the driver, I see console.
I installed Gnome and LightDM, set it as the display manager and installed the driver, but only saw console.

On Tue, 20 Jan 2015 20:56:01 +0000, sherif6 wrote:

> Hi, I’ve a HP laptop with Intel processor + AMD GPU and 64-bit OpenSUSE
> 13.2 KDE. The first time I install fglrx, I got to some fallback GUI
> mode then every time I try to install the driver, I see console.
> I installed Gnome and LightDM, set it as the display manager and
> installed the driver, but only saw console.

What specific AMD GPU do you have?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

It’s Radeon HD 7600M Series from YaST.

I have exactly same problem with radeon hd 7870xt

I can boot to GUI with open drivers after appending nomodeset to launch options

nomodeset use primate drivers so you have virtually no 2-d hardware acceleration and no 3d acceleration

It is fine for emergencies but you need a working radion or proprietary AMD driver