opensuse 13.2 won't run on Thinkpad X1 in UEFI mode (including rescue system and live image)

Hi All,

strange problem: OS13.2 won’t install on my TP X1 in UEFI mode. The process will freeze after loading the ramdisk (which is loaded successfully). I’ve read all the other posts on this (i.e., disabling apic, nomodeset etc). None of which makes any difference. Interestingly enough, I can’t even start the rescue system.

Now this could be a problem with my usb stick, however, when I enable legacy support in the Bios, the same stick boots up just fine. I also tried the live image, which works just great as long as I am not in UEFI mode. The minute I turn UEFI back on the systems hangs after loading the ram disk (live image, installer, or rescue system).

There is really nothing in the BIOS which should create this problem. So I imagine that either the BIOS prevent the kernel from starting because of a signature problem, or that that the EFI kernel on the USB stick is significantly different from the regular kernel.

Just for completeness, I tried another usb stick, and yes this is dual boor machiene with Windows 8 on it, the BIOS has been updated, secure boot is disabled, and 13.1 runs just fine on this machine.

Any pointers are welcome



Maybe a buggy UEFI. Try liveKDE and check from that if EFI vars are exposed. If so you can go with the install

would love to, but the live system won’t start either until I turn off UEFI. Just verified that it will run on another machine.

So you select to boot the device to EFI mode?? This usually require pressings a key during boot (F10 or F12 maybe depends on the EFI BIOS) What happens what options do you have what did you select. Depending on the EFI BIOS (not all are equal) you will have to manually chose the boot mode no mater what the system is set to.

The BIOS is set to UEFI only, so the live system starts using efi mode. If I set the BIOS to “both” the live system will start in regular mode, and work just fine.

Are you sure about that???

Just because it is set to EFI mode does not mean it will boot any arbitrary USB in EFI mode by default. be sure select the boot mode at boot.

If I use the regular install install image, I get the efi installer if I set it to UEFI, and the regular installer if I enable legacy support.

Ok it does not work…How does it not work??? All the crystal balls are in for service.

What video do you have these things are almost always video related.

the boot process stalls right after loading the initial ramdisk (which loads ok). Afterwards, nothing happens et all. This will happen regardless whether you try to boot the live image, rescue system or the installer.

I am aware that this could be a video issue, so I used nomodeset apic=off etc. I wonder however why the video would behave differently in UEFI mode (its Intel graphic)

Should not be different in EFI Intel should also be ok but the kernel parameter is nomodest to boot with generic driver

yup, I did that. used nomodeset, but the result is the same. It simply stops doing anything unless I disable UEFI