Opensuse 13.2 won't boot, cannot mount NFS folder

So yesterday I set up a shared nfs folder from my nas to my opensuse 13.2 laptop
It’s currently not set up right. I knew that. I never opened the ports on my firewall
So today I boot into my second windows partition and then try to boot back into opensuse
except it’s not working
I see something along the lines of “LSB: starting NFS Client Services”
“A start job is running for Network Manager”
and then it stops at “Reached target Graphical Interface”
and at that point I’m just stuck there, no terminal
all I can do is switch between the opensuse boot image and a screen of boot messages
Oh, and somewhere in there I see my nfs folder “/comics failed to mount”
I was trying to read comics directly from the nas since my laptop hard drive is kinda full
booting in recovery mode does nothing different

What should I do?

Boot live media or boot the install media in rescue mode.

Mount the root file system somewhere (usually at “/mnt”)

Edit “/etc/fstab” (which would be “/mnt/etc/fstab” in the rescue system.

Find the line for the NFS file system. Either comment it out, or add a “noauto” option.

Then see if you can boot.

Assuming that you want to mount the NFS file system via “fstab”, it is better to start with “noauto” so that nothing breaks. Then manually try to mount (something like “mount /comics” (depending on the mount point).

Only when you can get that working reliably, should you remove the “noauto”. And, maybe even then, add a “fail” so that mounting is allowed to fail during boot.

When you have time, I recommend looking into automounting (with the “autofs” system). That can ease the problems that can arise.

Thanks. I got it working doing pretty much the same thing.

I booted into single user mode. (Login to Single user mode in SUSE Linux (SLES / openSUSE))
press ‘e’ on the bootloader screen (where you select which OS to boot)
goto the kernel line (for me, starts with ‘linux’ and has ‘splash=silent’ farther along) and append ‘init=/bin/bash’
hit ctrl-x
open /etc/fstab and comment out the offending line
save and restart

I think if I want to avoid this in the future I add the ‘nofail’ option on that fstab entry. (fstab - ArchWiki)

If you have fast boot on in Windows it will leave the NFS partitions in a non mountable dirty state.