Opensuse 13.2 Re-installation

Hello everybody. i want to ask how can i reinstall my opensuse system without erasing my files? Let me tell you what happened: i was working with only my battery, somehow i did’t saw any alarm when my battery was critical, so it suddenly entered on hibernation. So i waited and started it again (with conected power) pressing spacebar. It recovered fine, so i went to check the battery management options and while exploring this options, the manager got stuck, so after a while, the system asked me if i wanted to close plasma-desktop. So i chose yes and it closed the desktop UI. So, i closed my programs and selected to restart my computer. It was shoting down but it got stuck again in the login cursor (when is turning the computer off). So, after some minutes waiting, i decided to force the turn off pressing power button for a time. Then, turned it on, entered on grub, selected my opensuse installation and then the splash screen showed a bit, then the screen turned black (the screen was not turned off) and got stuck there. Now it doesn’t want to enter the system, but it doesn’t show any error message. I tryed to enter recovery mode, but after showing some text on screen, it gets stopped and doesn’t show the recovery menu. So, after reading some similar problems, i think maybe the hibernation got screwed, and so the system. Can this be repaired reinstalling the system? Can i do it without erasing my files from my home directory? Thanks.

You can re-install and leave /home un-touched
Simply follow this route:

Ignore the proposal for the partitions when you initially start the installation and select ‘Create Partition Setup’
Then ‘Custom for Advanced users’
You should arrive at something like this:
Expand your hdd on the left and edit the mount points on the right side Eg:
With /home choose not to format:

Thank you, i actually tried something similar. Just didn’t mounted on /home directly. It seems my linux installation really got screwed. At least it didn’t screwed the data (i checked with fsck). I will never leave opensuse again without AC power. The critical battery alarm is not very efficient and can lead you to some problems. Now i’m making a backup and i’m going to reinstall a fresh opensuse. Thank you very much for the advice, worked wonders.