openSUSE 13.2 problems/no problems so fare.

Well maybe someone will tell me that 13.2 is not official released yet. What ever. The forum calculating of days to go is not make any sense to me.

I did upgrade (update?) my main DE from 13.2RC1 yesterday and the only problem I have seen so fare is that if I choose “restart” it will only work on my 2:nd monitor, giving me some… Thought. When I let it shut down and then start it is OK. HW is a AMD 3850 APU with built in GPU and dual 21"+ 20" monitors.
Did the same on my Laptop today and after a warning(I have learn that its a feature) its ticking like it should be :). Both PC’s where done by using “zypper dup” in 13.2RC1.

Yeeeessss!!! I dont have to look on this awful green color all over anymore (re-invented win95) at the startup screen. I can live with… :

Plymouth seem to be working during for the rest of booting process(I can live with that green/picture).

I notice some other things but have to verify using my laptop away from home.


It’s not officially released yet :stuck_out_tongue:

That did not stop me, either. I now have it on my main desktop.

Yes, I like the grub menu screen. This is better than RC1.

My only problem, is that the packman repo is not there yet. So I probably can’t play any MP3 files (I haven’t actually tried).

Yes, Plymouth is now working. With RC1, we saw a gray screen. With 13.2 final, we see the green wallpaper, initially very dim but growing brighter as the boot progresses.

Hmm, I liked that 13.1 default wallpaper. It would be nice if somebody would update the “gos-wallpapers” package (good old suse wallpapers) from its 2010 level to a 2014 level by adding the missing default wallpapers.

Why I’m early? I personally call it “promoting” “marketing” to let people know.

I agree upon that the KDE “Configure Desktop” and themes should offer themes to users a enviroment that they are familiare with.

:wink: always,



It was found impossible to upgrade from
openSUSE 20141011
openSUSE 20141029
using the wireless i/f on this pc

tried three times and each time the network traffic would stop,
only recourse was to reboot after each attempt

no problem found when updating via the wired i/f

setup :-

Kernel-3.17.2-1.g1afb260-desktop x86_64,
Mobo: A880G+, Quad core AMD Phenom II X4 965,
Graphics card: Advanced Micro Devices [AMD/ATI] RS880 [Radeon HD 4250] 
X.Org: 1.16.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz 
GLX Renderer: Gallium 0.4 on AMD RS880 GLX Version: 3.0 Mesa 10.3.1
Memory: 909.8/7746.2MB
Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169 
IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: 00:XX:XX:XX:XX:00
Card-2: Ralink RT5370 Wireless Adapter driver: rt2800usb 
IF: wlp0s19f2u3u1 state: up mac: 00:XX:XX:XX:XX:00

suggest: do not try upgrade if only wireless i/f available


ps. setting up wireless i/f still problematic, using either wicked or NetworkManager

I’m upgrading from 13.1 in 4 hours or so. That’s because Packman is being very slow this release, and there’s no 13.2 repository even at this hour… so I’m waiting till 12 AM and if not I’ll have to use the less stable Packman Factory :frowning:

Anyway is 13.2 working well for everyone else after upgrading? Should I be on the lookout for any issues specifically? Overall does it seem like a better and more stable release compared to 13.1?


addendum to post #4 above

seamlessly upgraded this morning from factory via wireless i/f
openSUSE 20141011
openSUSE 20141029

Kernel-3.17.2-1.g1afb260-desktop x86_64, KDE 4.14.2
HP Pavilion g7 Notebook PC-184B,
Graphics Card: Advanced Micro Devices [AMD/ATI] Trinity [Radeon HD 7640G]
X.Org: 1.16.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1600x900@60.01hz 
GLX Renderer: Gallium 0.4 on AMD ARUBA GLX Version: 3.0 Mesa 10.3.1 Direct Rendering: Yes
Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
        IF: wlo1 state: up mac: 00:XX:XX:XX:XX:00
Card-2: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller driver: r8169 
        IF: eno1 state: down mac: 00:XX:XX:XX:XX:00
Memory: 462.1/3361.4MB

previous anomaly due to unreliability of Ralink RT5370 Wireless Adapter driver: rt2800usb or hardware


13.2 up and running on HP6510b laptop (X86_64, Gnome 3.14.1, 3.17.2-1.g1afb260-desktop from Kernel-stable).

Two show-stoppers so far (after some 6h of active use):

  • 3G dongle doesn’t switch out of CD-mode (Huawei E173G: I had to reinstall usb_modeswitch-2.1.1-2.1.6 from RC1);
  • “Switch User” doesn’t work in graphical-target; likely related to GDM, since the “multi-user-target” works as expected on tty1:tty6.

Boot is rather slow at times, but this might be configuration-specific, if you prefer KDE.
Minor snags on Gnome apps, but this is of no interest to you either…
May be not ready for productive installations yet, but fairly close IMHO.

I upgraded from 13.1 to 13.2 last night. I encountered only one but very major issue:

grub2 is severely broken! After upgrading via “zypper dup” you’re left with a broken bootloader, which causes text to blink randomly then complains that there is no Kernel. It can only be fixed using a recovery console from the 13.1 DVD, to set up a new grub2 installation. I had to do this on both my PC and laptop to get the system booting again.

Upon closer inspection, I noticed that the version of grub2 included in 13.2 is marked as “beta”, which makes no sense for the stable release repositories! Even stranger, the web page doesn’t show a 13.2 version of grub2 at all, which is apparently marked as factory. See for yourselves over here:

I’m not bothered by this. As long as the opensuse team have done a good job of checking, it doesn’t matter that it is technically a beta release.

I don’t know what went wrong in your case. I have recently done “zypper dup” on three factory installs. Two of those used UEFI and one uses traditional MBR booting. I did not have any problems with those updates.

My only 13.2 final install was done from the DVD installer. I downloaded that from OpenQA (and I hope I found the right one – I’ll check when the public release is announced).

Problem: X sees two “Screens” caused by dual Intel / NVIDIA graphics (Optimus). This causes weird behaviour in the DE’s(cursor madness, windows opening off screen, i.e. the second screen that isn’t actually there. I fixed it by installing bbswitch and configuring it to load at boot, switch the NVIDIA off. Another “fix” is to disable the second screen through systemsettings / gnome settings.

Maybe something in Factory assured a better transition for grub2? I upgraded straight from 13.1, and maybe that broke something. Certainly a problem that should be looked into though… I was lucky I had a paper sheet with instructions and knew how to reinstall grub2, others might be left with a broken system after a DVD upgrade however (in case it wasn’t related to just “zypper dup”).

That’s a possibility. I have always preferred clean installs rather than upgrades.

An unbootable system doesn’t necessarily mean that GRUB2 is broken. I had no problems with that version too.
I had similar problems caused by the Yast/Bootloader module when installing in “unusual” situations (i.e. “non-default”).
For instance, marking the “Set active flag in partition table for Boot Partition” flag is likely ending up with a flag in the wrong place.
Setting the boot flag correctly by a recovery tool showed that GRUB2 was correctly installed and functioning, it was only reading the wrong information from the partition table.
A number of related bugs still open can be found by searching Bugzilla. As I understand, Yast2 has recently been rewritten and may still be in need of a few fixes.

True. It was grub2 in this case however… its interface and boot command were broken. Once I reinstalled grub2, everything else was fine and the system boots as normal. As for that flag, I think it was and still is active in the Bootloader menu in YaST… but the installer set it that way so I didn’t check it or touch it.

Is it possible that this is the same problem as was reported as bug 903736

Oh great. I was planning on doing a ‘zypper dup’ when I get home to upgrade and unfortunately I am not all that experienced with openSUSE (more experienced with Ubuntu).

So from what I am reading, it sounds like I should have the DVD .iso handy just-in-case. Thankfully I have a 2nd computer (desktop). Oh, that is actually good to know because I’ve been using Live Writer to make my live USB flash drive, but I have been doing that on the Windows partition which will likewise be inaccessible. So I can’t just download and wait, I need ot set it up beforehand (unless Unetbootin works with openSUSE?)

No do not use anything that modifies the iso if you plan on using USB just a binary copy. Last time I used cp /dev/sdX where sdX is USB device that makes a simple binary copy to the USB device (note not a partition)

Oh well… did ‘zypper dup’ and everything ran through but when I went rebooted it got to taking my username and password, and then saying there was an error and that it cannot log in.

It talkes a long time, though, to go back to the login screen. At least the Windows partition still boots.

So, now I am downloading the DVD image, and going to throw it on my USB. At least the estimated time to download has gone from 6 days to just under 2 hours! :slight_smile:

I installed 13.2 yesterday, clean install, I keep ext4 file system. No problems so far - only one old problem - suspend to RAM does not work with Nouveau driver. I had to install Nvidia driver “hard way”. It looks that suspent to RAM works now.

Downloaded the DVD. Did Dry Run of install program i.e. ran the program up to the Install point and stopped/aborted. I do this as a routine to understand the process and clarify doubts. Two questions came up.
First, there appears a new option to “load online repositories before install”. What is the significance? Does it mean that "all data will be down loaded again during install, or just that additional applications etc can be selected during the installation, to be downloaded during installation itself? I noticed that the DVD has Maria DB, whereas I would like to stick to MySQL.
Second point is the partitioning proposal includes a something “BIOS -Grub” partition. I have Open SUSE 12.3 and 13.1 on sdb going up to sdb6 (which I will be retaining). If I am not making a big mistake, in 13.1 one could choose not to install Grub afresh. What are the recommendations now, i.e. should I choose to install Grub afresh?